Sergiomar
Nintex Newbie

Workflow cannot be edited: Cannot open file "Nintex_AutoStartRules.xml"

Hi everyone!

 

I am in need of a helping hand:  In a Sharepoint 2013 System there are a couple of Nintex List Workflows that work correctly and have been edited (and published) several times in the past. Now is no longer possible to edit them. 

 

These workflows are correctly shown under "Workflow Inventory". When selecting any of them, it is possible to see the different steps and actions2019-12-04 15_17_42-KOE-ADMIN - TeamViewer.png

 

But as soon as I click on "Edit Workflow", I receive the error ErrorCannot open file "XXXXXX/Forms/Nintex_AutoStartRules.xml" and the Workflow editor appears completely empty (XXXXX is the name of the Library where the List Workflow is stored)2019-12-04 15_23_16-KOE-ADMIN - TeamViewer.png

 

If I try to open the Workflow by clicking on "Open" Button (on the Ribbon) the result is exactly  the same

2019-12-04 15_26_34-KOE-ADMIN - TeamViewer.png

The current editing user is the same one that created and edited (several times) the Workflow in the past. I have also tried with another user that is Site Collection Administrator. Same result.

Exporting and importing the Workflows again was of no help either.

 

I am currently desperate and I would be thankful to know if anyone has experience with this issue and/or any idea what is happening here. Thank you in advance for your help!

 

Regards

0 Kudos
Reply
1 Reply
SimonMuntz
Nintex Employee
Nintex Employee

Re: Workflow cannot be edited: Cannot open file "Nintex_AutoStartRules.xml"

HI,
1. Open the List in SharePoint designer and navigate to: All Files > The affected list/library > Forms
2. Find and Delete NintexAutoStartRules.xml
3. Re-publish any workflows set to start conditionally, this will re-create the NintexAutoStartRules.xml file.
0 Kudos
Reply