chanteldup
Cloud Wanderer

Unable to publish forms

Jump to solution

Hi,

I am new here... so we just got Nintex installed and I tried to test by creating my first form, I am able to save but not publish the form, when I click publish I get the following error:

The below post indicates that versioning is the cause of this but I checked and versioning is enabled as per the post. 

Unable to publish forms - You can only publish, unpublish documents in a minor version enabled list. 

Any idea what else could cause this problem?

ULS Logs:

Custom dictionary deployment timer job failed. SearchComponent: OWSTIMER.EXE, SearchServiceApplication: {2abad414-bfb4-4d49-95a2-58deea2f3f63}, FlowName: Microsoft.CustomDictionaryDeployment, CorrelationId: {2b6b2d9e-55ae-50d0-016b-c9eb0f92713b}, Failure: System.InvalidOperationException: Failed to connect to system manager. SystemManagerLocations: net.tcp://[myserver]/E9D620/AdminComponent1/Management ---> System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://[myserver]/E9D620/AdminComponent1/Management/NodeController. The connection attempt lasted for a time span of 00:00:02.0313218. TCP error code 10061: No connection could be made because the target machine actively refused it [myserver IP]:808.  ---> System.Net.Sockets.SocketException: No connection could be made... 2b6b2d9e-55ae-50d0-016b-c9eb0f92713b

0 Kudos
Reply
4 Replies
praios81
Ribbon Ruler

Re: Unable to publish forms

Jump to solution

Hi Chantel,

does this happen to all forms you try to publish or is this happening just with this specific form?

If you create a new custom list, add a form and directly publish it, does it publish correctly or does the problem also exist in this scenario?

The error message you showed in your screenshot is different to the link you found. Your error message basically states "Invalid field name" while the error in the linked article is "You can only publish, unpublish documents in a minor version enabled list." so I don't think versioning is the problem here.

I think this is the right link to help:

Error "The server encountered an error processing request. The exception message is 'Invalid field n... 

If the problem is present on the plain custom list too, can you please try the steps mentioned in the resolution?

Best regards

Enrico

View solution in original post

0 Kudos
Reply
chanteldup
Cloud Wanderer

Re: Unable to publish forms

Jump to solution

Morning and thank you so much for the reply! I will be trying this today and advise if this resolves the problem.

0 Kudos
Reply
chanteldup
Cloud Wanderer

Re: Unable to publish forms

Jump to solution

Good Morning,

Apologies for the delayed response, just wanted to update that the fix worked and forms are now publishing successfully!

Reply
Fitzw12
Design Dabbler

Re: Unable to publish forms

Jump to solution

I'm having a similar issue but I don't have any error icons on my control fields, and all controls are connected to the correct List field.  The error I get is regarding the layout. "Error - Publish has been disabled. The following layouts have incomplete configuration: Desktop." No idea what this means. All other Nintex forms and workflows work. This one just suddenly stopped working. Any ideas?

Tags (2)
0 Kudos
Reply