Nintex list form webpart Edit mode not working?

so some background;

I have a custom list where users can subscribe to a mailing list and add themselves to this list using the nintex form (in new form mode) and I have made a 'manage subscriptions' form as well (which is the edit form)

The edit form just has a few checkboxes and users can select what they want and then starts a nintex workflow to remove themselves from the mailing list. 

I've made a new page with the list to show only the user's subscriptions and no access to other views to see other people's subscriptions.

This page also has added a Nintex list form webpart linked to that view from the list but in edit mode. It shows the edit form fine, but the problem is that the 'selection' is always defaulted to the first item in the list and does not delete what was selected), I cannot find a way to change what is selected on the form to be deleted.

alternately, there was one time the form worked, but broke adding ANY new items to the list. I discovered that when setting the connections to the list I accidentally selected the 'set vales to' (which that form overridden anything to that list), but the connection 'get values from' works but too passive to make any changes. (I feel like there needs to be a getter and setter type style.

The only time that the edit form has worked correctly (besides the overriding stated above) is by adding the column "Edit (link to edit item)" to the view "my subscriptions". Users click the little icon created by that column and it goes to the nintex form in edit mode (the deletion form) and users are able to correctly delete what they have selected.

There was nothing changed between what was written above and the bolded part in terms of the form or the workflow. I believe this may be a bug, but off chance i'm not setting the connections correctly (even though there was only one option to select now) of the list form webpart to the subscription list.

See image attachments for a bit more visual feedback.

Cheers, Jack

0 Kudos
1 Reply

Re: Nintex list form webpart Edit mode not working?

this should be possible to configure.

I'd suggest to start over building page from scratch.

- remove all the webparts

- add list view webpart and configure it

- add list form webpart and configure it

- from list form webpart select connections >> get rows from >> list view's webpart source list. once you setup the connection there should appear new column 'Select' in list view webpart which makes a selection for list form webpart.

0 Kudos