trol
Rookie

List Form webpart

Jump to solution

Having a lot of problems with this one. Does anyone have a good resource/guidance on actually configuring the List Form webpart in 2016 and making it work?

 

I can find all kinds of half-complete posts/videos/tutorials but nothing seems to actually work.

 

Basically, I want to display the edit form on a page on my site. I have the form good to go but, I just can't find the information I need to get the web part to work.

 

Nothing I put in for SSite URL, Listname/ID, or ItemID results in anything but a blank page that can't be recovered. I always have to go in and delete the page then try some other random set of inputs (based off of what little information I can find on configuring the webpart) to try to make it work.

 

I'm at about 200 attempts at this point, about ready to find a different product to meet my needs.

 

Any help would be appreciated.

Reply
4 Replies
emha
Collaborator

Re: List Form webpart

Jump to solution

what version are you on? are you on latest one?

 

recently there seem to be addressed several issues with webparts.

see release notes - https://community.nintex.com/t5/Release-Notes/Nintex-Forms-2016-Release-Notes/ta-p/87904 

 

one of addressed issues seems very close to what you experience

  • Fixed an issue where a Nintex Form web part may render as blank (00202161; 00209402; 00211704; 00212976; 00213357)
0 Kudos
Reply
trol
Rookie

Re: List Form webpart

Jump to solution

Thanks for the find. Let me check.

0 Kudos
Reply
trol
Rookie

Re: List Form webpart

Jump to solution

We're on the latest version so that's not it.

 

However, I did discover that so long as I modify the list form for the list in question (vs. trying to make a seperate page). It's flaky and I have to delete (and re-add) the Nintex web part to modify any of the other web parts but it works.

 

Important things to note:

 

The Site URL stays blank

The list name is the name of the list (ie. if the list name is user requests use user requests, no quotes, no slashes, just the two words.

 

If you're using "new" as the form type, use Item as the content type.

 

Ultimately, I'd like to get this to work on a seperate page but, for now, I can at least move ahead with the project.

 

 

 

 

 

0 Kudos
Reply
kpope
Scholar

Re: List Form webpart

Jump to solution

I am configuring this to rollup CURRENT USER's active forms on a different site. I appreciate your notes!  As I configure, I want the CURRENT USER to ideally click the name of the form (that is/will be InProgress) and view the DISPLAYform.  What then is the ItemID?  ItemID is required. 

0 Kudos
Reply