Duplicated Nintex site columns

Jump to solution

Dear all,

I have an issue in my SharePoint farm.

I've found duplicated site columns on a specific site (I guess this is coming from a previous wrong backup-restore of the site). I've cheked also the site collection level and other sub-sites and it's working fine. It only affecting to this specific site (named "Generic Workfow v2").

The duplicated columns are inside the "Nintex Workflow" group (Associated Content Type)

This is generating an error when I try to associate a site column on a specific Content Type. I've found this on the ULS logs.

System.ArgumentException:No two choices should have the same ID

I've tried to delete these sites columns, but SharePoint doesn't allow me to do it.

Site columns which are included in content types cannot be deleted. Remove all references to this site column prior to deleting it

I've found references of these columns in the hidden list "NintexWorkfows". Columns are used as metadata in this list.

¿What can I do to change these wrong references to the new ones? ¿Can I for instance export all my WF in this site, deactivate the Nintex Feature, delete the "NintexWorkflows" list, then activate the feature again (is regenerating the "NintexWorkflow" list from the scratch?), import my original WF and try to delete the site columns then?

¿Can I simply delete the columns on the "NintexWorkflow" list and associate the correct site columns instead?

I'll appreciate any kind of help.

Best regards.

0 Kudos
2 Replies

Re: Duplicated Nintex site columns

Jump to solution

Eventually I solved it!

It was no way to delete theses CT by PowerShell, SharePoint Manager o other tools...

As I suspected, the only way to fix this was directly on the content database. I've followed a procedure quite similar to this one:


Now the wrong CT are no there anymore and it’s working perfectly!

View solution in original post

0 Kudos

Re: Duplicated Nintex site columns

Jump to solution

The link referenced in the solution doesn't appear to work any longer. 


Here is what we had to do to fix this in our case. 

  1. Navigate to Site Content Types at the top level of your site collection
  2. Modify the Workflow content type (under the Nintex Workflow category)
  3. Remove these two fields from the content type (You don't need to have it update content types that are inheriting)
    • Associated Content Type
    • Category
  4. Navigate to the Site Columns at the subsite level where the error was occuring
  5. Delete the 2 offending fields - make sure you select the correct ones
  6. Go back to the Workflow Content Type at the Site Collection level
  7. Add the 2 fields back in. (Be sure to select the correct "Category" field. There might be multiple. You would see a Group Description below the selection field. Select the Category field that is in the Nintex Workflow Group)

You should be good to go now!

0 Kudos