cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
glenda
Nintex Newbie

Workflow variable in task form not populated

Jump to solution

Hi guys, 

I am working with Nintex for Office 365 and what I want to achieve is that an approver of an approval task can fill out a field on the task form of type "People". In the workflow I need to use the person that was provided. 

I have tried two scenario's:

  • Adding a person or group field to the Tasks List to all content types. The field does not show in my task form editor window in the Task Columns category nor within the "Connected to"-section. Also not after saving/refreshing my window.
  • Adding a workflow variable of type string which I connected to the People field on the form. When filling out the form and logging the contents of the variable afterwards in my workflow, it remains empty. 

Anyone having the same issue, or did someone get it working or maybe has a different solution? 

I am using Nintex responsive forms (and I would like to keep it this way as currently all my other forms are built in the responsive forms builder as well).

Kind regards, 

Glenda

Reply
3 Replies
abdullahfahmi91
Nintex Newbie

Re: Workflow variable in task form not populated

Jump to solution

Hi ‌,

Have you tried Edit Task Form in the Task action inside the Workflow Designer?

0 Kudos
Reply
glenda
Nintex Newbie

Re: Workflow variable in task form not populated

Jump to solution

Hi ‌, 

Yes, I am editing the task form trough "Edit task form" from the workflow designer window in my start a task process action.

Best regards, 

Glenda

0 Kudos
Reply
glenda
Nintex Newbie

Re: Workflow variable in task form not populated

Jump to solution

Guess I am not getting it solved on an already available content type.

The following workaround seems to do the trick, but creating a new content type is necessary:

  1. Create new content type through site settings (inheriting from Workflow Task). Create the site columns you need as well. 
  2. Add the necessary site columns to the content type.
  3. Add the newly created content type to your workflow tasks list the workflow is using. 
  4. Go to your approval action (or create a new one) and select the content type from the list. 
  5. Choose Edit task form and make the necessary modifications to it. In this case my data actually gets stored  

View solution in original post

Reply