VishalS
Novice

K2 Blackpearl Service not getting started

Hi ALL,

 

I did a fresh Install for K2 Blackpearl 4.6.8 with developers license and after successful installation ,i'm not able to start K2 BP service directlty or through console.

 

Actually In the beginning of installation,I was facing some issues related to K2 database saying "database is of wrong type" and even after providing all the access and with correct DB collation ,I was not able to fix it.So i took a K2 DB back up of one of our old K2 development enviroment and restored the same in the new  K2 development environment and the issue for the same got fixed.

But after the installation,On start of K2 BP service through console mode,It is pointing to the old server name instead of new one and the old one no more exists.

 

Please help me out to fix this issue.

 

Regards,

Vishal


consoleserviceerror_1931.png
service_error_1932.png
0 Kudos
Reply
5 Replies
SATYAJEET
Novice

Re: K2 Blackpearl Service not getting started

I guess as it is a developer edition , you cannot start the server as a windows service

You have to start it in console mode

 

Modify hostserver config file to enable logging and check the host file

 

Thanks and Regards,

Satya

0 Kudos
Reply
SATYAJEET
Novice

Re: K2 Blackpearl Service not getting started

One more thing you can try is a fresh install of K2.

Let it create a fresh databse and I am sure everything will go through smoothly

0 Kudos
Reply
VishalS
Novice

Re: K2 Blackpearl Service not getting started

Hi Satyajeet,

 

When ever i try to create a fresh k2 database,everytime i get error like "Database is of wrong type" even after following all the required rules. 😞 

Do you have a proper steps which should be followed while creating a K2 DB?

What I follow is mentioned below:

1.Create DB with name K2 

2.Select  collation type as SQL_Latin1_General_CP1_CI_AS and Recovery model as full.

3.Grant all the server roles to the account user.

 

Is there anything which I'm missing?

 

Regards,

Vishal

0 Kudos
Reply
SATYAJEET
Novice

Re: K2 Blackpearl Service not getting started

Hi VishalS,

 

What I meant was drop any existing K2 database from the Sql Server Instance to which K2 is going to connect.

Let K2 installer create the K2 database during the installation process.

 

Thanks and Regards,

Satya

Reply
Ziqing
Apprentice

Re: K2 Blackpearl Service not getting started

You can try checking the compatibility level of the database under database properties > options. I encountered the same error before and playing around with the SQL compatibility level helped to resolve it.

Reply