Code Fix: The K2 Workflow email event format is returned incorrectly when copied from Microsoft Office products
KB002383
PRODUCTK2 Five 5.0
K2 Five (5.0) Fix Pack 23
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.
Issue Description
When you use K2 Package and Deployment to deploy a workflow with an email event that contains HTML formatting copied from a Microsoft Office product, and then edit that email event, the HTML formatting is lost.
Cause
Invalid XML characters.
Resolution
- Ensure you have K2 Five RTM installed.
- Get the K2 Five RTM FP23 from Regional Support.
- Close off K2 Package and Deployment.
- Install the K2 Five RTM FP23 to apply the fix.
- It is recommended to refresh the browser cache.
Consideration
You must re-deploy the workflow on the source environment and then re-package the solution to deploy on the target environment to fix the formatting issue.
