Exchange Online Configuration - EWS URL could not be validated


Exchange Online Configuration - EWS URL could not be validated

This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.


When using SmartActions, the "Completing a task via email replay" is not working and a message appears: EWS URL could not be validated. Do you want to continue with this URL?


Server stack trace presents the following: at Microsoft.Exchange.WebServices.Autodiscover.AutodiscoverService.InternalGetLegacyUserSettings[TSettings](String emailAddress, List`1 redirectionEmailAddresses, Int32& currentHop)




After changing our email address from Exchange Server 2013 to Exchange Online, you will encounter the problem with the Exchange Server Configuration when rerunning the K2 Blackpearl Setup Manager.  


After setting the "Configure Exchange Online" input the Email address and Password and EWS URL, the mailbox can be accessed through O365 email web.


By performing the following steps the error was corrected and SmartActions were accepted by Exchange Online:


1. Proceed with the installation when K2 Setup Manager prompts that the EWS URL cannot be validated

2. Once done, go to [Program Files]\K2 blackpearl\Host Server\Bin, and open ConnectionStringEditor.exe

3. Select your Exchange connection string, and change Auto discover to False

4. Retest the URL.


Labels: (1)
Version history
Revision #:
2 of 2
Last update:
‎05-20-2021 07:06 AM
Updated by: