cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Nintex Forms Preview is showing empty

Jump to solution

I have a Nintex Form that shows blank on both Preview, New and Edit Form.

I have attached the form.xml for your reference.

I have done the following to try fix this problem.

  1. Removed all Calculated Controls and Rules on the form.
  2. Reverted changes, using Version History to the version that it doesn't have Calculated Controls (via Nintex Forms)
  3. Exported and Imported form.xml to another new custom list.

Here is my form:

Form.jpg

After clicking Generate Preview:

EmptyPreview.jpg

Labels: (3)
Tags (2)
Reply
6 Replies
christopheraucq
Nintex Newbie

Re: Nintex Forms Preview is showing empty

Jump to solution

Hi Darwin,

I have the same issue if the form contains not well formed Javascript.

Do you have any?

Regards,

Christophe

Reply
mlauer
Nintex Newbie

Re: Nintex Forms Preview is showing empty

Jump to solution

You are right Christophe. That's my practical experience.

Darwin, to check this activate the development tools und look at errors in console window.

Kind regards

Manfred

0 Kudos
Reply
Not applicable

Re: Nintex Forms Preview is showing empty

Jump to solution

Hi Christophe,

I didn't add any custom Javascript or CSS.

Regards,

Darwin

0 Kudos
Reply
Not applicable

Re: Nintex Forms Preview is showing empty

Jump to solution

Hi Manfred,

I will try to your suggestion.

So far, I was able to able generate preview by deleting all Date-picker controls.

But when i try to add a Date-picker control, it won't generate preview again.

I was able to export the form on another environment and it worked just fine.

I'm guessing that there's something wrong with my environments' Nintex Forms.

Regards,

Darwin

0 Kudos
Reply
Not applicable

Re: Nintex Forms Preview is showing empty

Jump to solution

Hi All,

I was able to resolve the problem by doing the following from https://community.nintex.com/thread/2252#7085

In the web.config of the web application , there is a “compilation” key . I updated the "debug" property of the key to “false” and reset IIS. The forms are working fine after the change.

<compilation batch="false" debug="false" optimizeCompilations="true">

Regards,

Darwin

0 Kudos
Reply
baltner
Nintex Newbie

Re: Nintex Forms Preview is showing empty

Jump to solution

Darwin:

Thanks for this suggestion.  I was seeing the blank view of the form (in both Preview and when adding new documents through the list) after importing it into a new development SharePoint farm. Setting debug to "false" did fix the problem.

Thanks!

Bruce

0 Kudos
Reply