Solved

Form plugins - workflow comments

  • 18 October 2023
  • 3 replies
  • 96 views

Userlevel 1
Badge +6

I have downloaded the Workflow comments plugin but I can't seem to add it to my tenant. 

First, the instructions say to “Import the plugin and use the Element name: wf-comments.” I guess I’m not understanding how to import the plugin, nor which JavaScript file I’m supposed to upload. When I downloaded the plugin and extracted the files, there are two folders - _MACOSX and workflowcomments - each of which contains five JavaScript files. I assumed I would use the file called workflow-comments (in the workflowcomments folder), so I tried uploading it and using the Element name as described. But I get the error “Failed to load the plugin definition.” In fact, I get this message regardless of which JS file I try to upload.

I have also tried copying the JS files into a SharePoint folder and using the URLs. Same error message.

I have successfully imported other plugins to my tenant. What am I doing wrong with this one?

icon

Best answer by SimonMuntz 20 October 2023, 00:22

View original

3 replies

Userlevel 6
Badge +22

Hi @DavidAD 

If you host the files on a public-facing site like GitHub, does that help?  Hosting on SharePoint won't work as it requires credentials to access them, and those credentials are not sent.

I am guessing that the previous plugins you used only had one.js file. As this has multiple files and the first file imports at least three others, it errors as those files are not accessible.

Userlevel 1
Badge +6

Hi, @SimonMuntz - I don’t currently have access to a public-facing site, but I’ll look into it. Thanks!

Userlevel 7
Badge +11

@DavidAD A little late to the party, but if you are still looking there is info in the help files to get started with using github to host your files. 
https://help.nintex.com/en-US/formplugins/Reference/Hosting.htm

Reply