My K2 5.4 install will only go to 'Recover' and then fails due to a blocking error

  • 13 September 2022
  • 6 replies
  • 9 views

Badge +2

I attempted to install K2 Five (5.4) on my machine in order to be able to get VS (hopefully VS 2019) to view the K2 projects for our work. 



 



However it failed to work and now I can't even uninstall the software because the only option given is Recover and that fails. 



 



Can someone aid me? Thanks. 


6 replies

Userlevel 2
Badge +6
The InstallerTrace log shows that the K2 Configuration Service cannot start.
Look at the logs in the c:Program FilesK2SourceCode.Configuration.ApiLogs directory, you might find something why the service won't start.
Badge +2
Thanks but there is no Log folder there. The only recent logs in the K2 folder are the ones from my two attempts to run Recover.
Userlevel 2
Badge +6
And is the K2 Configuration Service among the services? Have you tried starting it manually? What are the Error or Warning events in the Windows Event Log (application and system) after that attempt?
Can you check, using the command:
netstat -ano | findstr ":5560"
to see if there is some other process listening on TCP/5560 port, which could prevent the service from starting.
You might find something.

Personally, I'd never install K2 on my work machine, but on a separate virtual machine where I can take a snapshot and revert it to the previous state in case of trouble, and on the server operating system.
Badge +2

And I prefer to follow my work's protocol regarding my machine. 



 



The configuration service doesn't start because 



 



Error 1068: The Dependency service or group failed to start.



 



Event viewer has a NETLOGON error: "This computer is configured as a member of a workgroup, not as a member of a domain. The Netlogon service does not need to run in this configuration"



 



So, yes, since we are no longer on AD under the new distributed working system and because K2 is still stuck with AD I know you can't run the system on your machine any more. However, in the 4.7 days you had to install k2 to get the ability to open and work on k2 processes in Visual Studio. 



 



No idea if that's changed but it's utterly farcical to create a piece of software that can't even be uninstalled because it relies on a service that might fail to uninstall itself.



 



I guess I'll have to open a support issue.

Userlevel 2
Badge +6
Oh, I see, that pretty much explains it. I installed K2 Five 5.0 in workgroup a long time ago, and it worked. Never since. The support ticket is the best, of course. It would be nice if you could post here in the forum how you solved it. Good luck.
Badge +2

Sure, will do.



 



If it's anything like the last time I had problems with an install the K2 guys will have to remotely access my machine and give me a tool to remove it that I have to delete immediately after!

Reply