Error When Updating Salesforce Record: Provided external ID field does not exist or not accessible

  • 19 August 2020
  • 5 replies



I am receiving this error when trying to update a Salesforce record at the beginning of a component workflow.


Full Error Message: {"error":"request id: 5f3d74f1e4b09209fe15ff17 response code: 404, message: Provided external ID field does not exist or is not accessible: [], provider message: "}


Here is the initial actions of the workflow:


The "update a record" and "retrieve opportunity field" actions both reference the same Salesforce ID. The update action will throw the mention error when running the workflow. If I disable that action, the all other uses of the ID work fine, including another update action later in the workflow. 




I tried to do some googling on this issue with no luck. I'm not exactly sure if this is a Nintex issue or something to do with Salesforce and how it handles these integrations, but was wondering if this was anything other people might know a workaround for. 

The main point of confusion for me is why the update seems to not work when it is used at the beginning of the workflow, but performing an update action on the same ID later in the workflow has no issues. Seems like some sort of timing issue.

5 replies

Userlevel 5
Badge +13

@jwCbank It may be something is already trying to update record, have you tried adding a short pause at the start of workflow to see if it is something to do with the record being locked. Additionally it might be worth reaching out to our support team( as you are receiving an error.


Userlevel 5
Badge +19

@jwCbank assuming that you're using the same connection throughout the workflow that does seem like some type of "conflict" error. In the workflow or process that calls this workflow, is there anything that is already interacting with that given record that might put some type of lock on it?

That must be the case. I'll have to look at our systems and see.
Userlevel 5
Badge +19

@jwCbank did you ever find if something was putting a lock on the record?

@butlerj It definitely doesn't seem like anything is locking the record. I did end up raising a support team ticket the other day. Will hopefully get some more information from them