cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Nintex form 'tabs' do not display default tab in Edit Properties mode

Just to be clear, the tabs actually are working most of the time. I've implemented the tabs using rules and panels, as one would expect. Here, the default tab specifically will not display on the initial load when you go into "Edit Properties". It seems to be some sort of issue where it's looking for the last tab used, but can't find one and doesn't use the default that was set (I think). This can be solved by clicking on the other tab, which displays properly, and then clicking again on the original tab, after which there's no more problems.

To avoid confusing a user, however, I'm looking to make sure that the default tab does display in edit properties when the page first loads. I've tried using some custom JavaScript to do the above solution automatically, but none of my code is being run on the site (as opposed to preview in nintex, but the problem isn't possible to replicate in preview mode).

My question is how can I make sure that it displays initially? Whether it be by custom JS or settings, I can't see a way to fix it.

There is one error in console that is thrown that I'm not sure if it's relevant, though since it looks to be in the nintex source might be something common that I don't know about (though I'm suspicious that it might be blocking the running of my JS).

Attached are images of what it looks like after the initial load, what it looks like after switching tabs, and the console error. I'm glad to provide other information as needed as well.

Thanks in advance.

Tags (2)
Reply
9 Replies
Highlighted
Not applicable

Re: Nintex form in sharepoint will not display tab in edit mode

So I managed to solve my specific problem, but there still is left the problem of the dissapearing defaults in edit properties mode. I have no clue if it's purposeful or not or if there's any way to disable/re-enable that. If anyone can provide some insight into that, that would be great, thanks.

Reply
yvette
Nintex Newbie

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

Hi Nathan,

I have the same problem! Could you please tell me how you were able to make the default tab display correctly on the initial loading of the form?

Kind regards,

Yvette

Reply
loi0404
Nintex Newbie

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

Hey Nathan, I'm having an identical issue. I'm curious what your default tab fix was.

Reply
Not applicable

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

I had to change my approach rather than solve the problem. I was able to get by using some buttons to toggle the results instead of using the tabs

Reply
stevebnc
Nintex Newbie

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

I tried a lot of ways and was able to get a "default tab" behavior to work by simply by not entering a default value in the choice control and using an "and is not blank" statement in the rule that hides the panel I want for default.

eg. and(Tabs!="Main",Tabs!="").

Edit: disregard the above, as this does not seem to be working after a save is performed ( I was just looking at the initial load and then view). Back to the drawing board or this might just be something I have to live with. It seems counter intuitive that this is not an OOTB variable function. Where the form button values are being stored?

0 Kudos
Reply
stevebnc
Nintex Newbie

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

Ok so this really bugged me and not being one to give in I looked at this all morning and found a solution that seems to be working.

  • I created a single line column called "Tab" (I tried choice (buttons) which worked as well ). I made that column's default value "Main" (which is my first Tab) . On my form Choice Control for the Tabs I connect it to that new column called "Tab". Note there seems to be some real idiosyncrasies with what happens to the buttons when you connect the control. I can't exactly determine what causes it sometimes to change into radio buttons as opposed to the tab buttons (and seemingly impossible to change back). Though I have had better success using the ribbon to set the connected to field.
  • On the form I put a calculated Value Control. That control also connects to the new "Tab" column. I set the formula to be 'Main" as a string. I made that control invisible so it does not show up.
  • When I save a form with a new tab selected it saves it back as "Main" based on the calculated control and when I open up the form it is now back on the main tab.
  • I found I had to make sure the calculated control was below the choice control. It appears that the form is reading the controls in order and submits the last one (bottom). I found this link http://help.nintex.com/en-US/nintex2016/current/sp2016/Forms/CreatingForms/ConnectingControls.htm confirming that. It gives a cautionary about fields being connected to more than one control but in this case I think I can leverage the behaviour to "reset" the value.

Whether this is a good way to go, who knows. I'm weary of creating more pseudo-data columns but I will run with it for now. Anyone else tried this or see any issues with this?

Reply
noaal
Nintex Newbie

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

Hey Steve,

I was looking for the solution for quite sometime now. I have tried your steps. It worked fine for me. Did you experienced any issue by connecting two controls to a single column lately?

0 Kudos
Reply
stevebnc
Nintex Newbie

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

Hi Noa, glad to hear it worked. This is the only scenario I have used multiple controls on a single column and I haven't noticed any issues. (other than having to add extra lines to my documentation ) If I run into any I will post it here.

Reply
noaal
Nintex Newbie

Re: Nintex form 'tabs' do not display default tab in Edit Properties mode

Thanks Steve for your quick response. Sure, please update if there's any issue. It will help the community. Thanks again !

0 Kudos
Reply