pcorearusa
Novice

Unable to add K2 app for SharePoint on Prem

We are in the process of installing K2 on our on Prem. Most of the K2 products are installed. We uploaded K2 fo SharePoint app to the app catalog. provided necessary metadatas. And now we try to add that app to the site (site>>sitecontents>>add an app >> Selected K2 for SharePoint. It says "we are adding your app" message but never completed. At certain poing we see this message next to that app: "Sorry, something went wrong with adding the app. Click to retry." We try to install test K2 app frovided with this installation. that works fine. and also we have installed other apps from SharePoint app store too. Some of the apps including K2 app in SharePoint store are greyed out with message " [images attached]


onpremapp_2008.jpg
spstore_2009.jpg
0 Kudos
Reply
1 Reply
JRoberts1
Apprentice

Re: Unable to add K2 app for SharePoint on Prem

Hi pcorearusa,

First, not knowing all the steps you've followed thus far, I assume since you are in the process of installing K2 for SharePoint 2013 On-Prem, you're following the instructions from this guide?

SharePoint 2013 (On-Prem) Installation
 

Typically, the K2 for Sharepoint installation is part of the steps within the full process of installing your K2 Blackpearl Server, or it's an add-on installation if you're installing later. Without much more information to go on, you may want to contact our customer support group to open a ticket. They can help you figure out where you need to be to get the app working correctly.


Customer Support Info

 
Regards,

Jason

0 Kudos
Reply