Solved

Error message in browser when previewing a form

  • 26 December 2022
  • 4 replies
  • 714 views

Badge +2

When i wat to preview a form i get a error message not from nintex but from the browser while loading the form. If i however publish the form and view it as a form there is no problem. the form loads just fine.

Any help “decoding” the error message would be helpful.

This is the error message the browser (firefox) gives me:

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>Request Error</title>
    <style>BODY { color: #000000; background-color: white; font-family: Verdana; margin-left: 0px; margin-top: 0px; } #content { margin-left: 30px; font-size: .70em; padding-bottom: 2em; } A:link { color: #336699; font-weight: bold; text-decoration: underline; } A:visited { color: #6699cc; font-weight: bold; text-decoration: underline; } A:active { color: #336699; font-weight: bold; text-decoration: underline; } .heading1 { background-color: #003366; border-bottom: #336699 6px solid; color: #ffffff; font-family: Tahoma; font-size: 26px; font-weight: normal;margin: 0em 0em 10px -20px; padding-bottom: 8px; padding-left: 30px;padding-top: 16px;} pre { font-size:small; background-color: #e5e5cc; padding: 5px; font-family: Courier New; margin-top: 0px; border: 1px #f0f0e0 solid; white-space: pre-wrap; white-space: -pre-wrap; word-wrap: break-word; } table { border-collapse: collapse; border-spacing: 0px; font-family: Verdana;} table th { border-right: 2px white solid; border-bottom: 2px white solid; font-weight: bold; background-color: #cecf9c;} table td { border-right: 2px white solid; border-bottom: 2px white solid; background-color: #e5e5cc;}</style>
  </head>
  <body>
    <div id="content">
      <p class="heading1">Request Error</p>
      <p>The server encountered an error processing the request. The exception message is 'Limiet van secundaire versie overschreden.

U moet eerst een primaire versie publiceren voordat u dit document gaat wijzigen.'. See server logs for more details. The exception stack trace is: </p>
      <p>   at Microsoft.SharePoint.SPFile.SaveBinaryInternal(Stream file, Int64 fileSizeToSave, ISPFileStreamManager spmgr, Boolean isBackgroundSave, String checkInComment, Boolean checkRequiredFields, Boolean autoCheckoutOnInvalidData, Boolean bIsMigrate, Boolean bIsPublish, Boolean bForceCreateVersion, String lockIdMatch, SPUser modifiedBy, DateTime timeCreated, DateTime timeLastModified, Object varProperties, SPFileFragmentPartition partitionToCheck, SPFileFragmentId fragmentIdToCheck, SPFileFragmentPartition[] fragPartitionsToDelete, String csvPartsToDelete, Stream formatMetadata, String etagToMatch, Boolean bSyncUpdate, SPLockType lockType, String lockId, TimeSpan lockTimeout, Boolean refreshLock, Boolean requireWebFilePermissions, Boolean failIfRequiredCheckout, Boolean validateReqFields, Guid newDocId, Boolean bypassMaxFileCheck, Boolean bypassQuotaCheck, Boolean bypassVirusScan, SPVirusCheckStatus newVirusStatus, Int32 newVirusVendorId, String newVirusInfo, Byte[] newVirusInfoEx, Boolean bUseTimeLastModified, Boolean bUseTimeCreated, Boolean persistBITSInfo, Guid BITSSessionId, Guid originatorId, String multiAuthEditActivityUserIds, SPVirusCheckStatus& virusCheckStatus, String&amp; virusCheckMessage, String&amp; etagReturn, Boolean&amp; ignoredRequiredProps, SPFileInfo&amp; fileProps)
   at Microsoft.SharePoint.SPFile.SaveBinary(Stream file, SPFileSaveBinaryParameters parameters)
   at Microsoft.SharePoint.SPFile.SaveBinary(Stream file, Boolean checkRequiredFields, Boolean createVersion, String etagMatch, String lockIdMatch, Stream fileFormatMetaInfo, Boolean requireWebFilePermissions, String&amp; etagNew)
   at Microsoft.SharePoint.SPFile.SaveBinary(Stream file)
   at Nintex.Forms.SharePoint.NFDocumentLibrary.&lt;&gt;c__DisplayClass17_0.&lt;SavePreviewForm&gt;b__0()
   at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)
   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)
   at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)
   at Nintex.Forms.SharePoint.NFDocumentLibrary.SavePreviewForm(String formId, MemoryStream formStream)
   at Nintex.Forms.SharePoint.Services.NfWcfService.SavePreviewForm(Form form, IList`1 fieldListCollection)
   at SyncInvokeSavePreviewForm(Object , Object[] , Object[] )
   at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]&amp; outputs)
   at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc&amp; rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc&amp; rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc&amp; rpc)
   at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)</p>
    </div>
  </body>
</html>

icon

Best answer by MegaJerk 3 February 2023, 23:10

View original

4 replies

Badge +2

It happened to me Also 4 days ago, without any solution still,

any help will be highly appreciated.

Userlevel 5
Badge +14

You are likely running into a minor versioning limitation, and need to publish the form from the NintexForms library manually. For some reason when hitting this limit, it can become difficult or impossible to correctly publish the form from within the Form Editor.

 

Navigate to the site list / library of where your problem form is located, and then change the URL from:

http://yourDomain/sites/MainSite/SubSite/Lists/YourListName/View.aspx

to 

http://yourDomain/sites/MainSite/SubSite/NintexForms/Forms/AllItems.aspx

 

This will take you to a library called NintexForms which contains the xml of every form for that given site.

 

First thing I recommend that you do is to click on the three little dots and go to Modify This View:

 

Inside of the View Editor, check the “Version” checkbox:

 

And then scroll back upwards and click on the OK button in the top righthand corner to save the View:

 

This will show you which forms have the highest minor versions on the Library. Find the form with the same versioning as the Form you’re having troubles with (if you actually open your form in the design mode, you will see it’s current version in the top right corner of the Form Editor), it will likely have a large minor version number which is the value after the dot as shown:

The delimiter for Major.Minor versions may differ depending on your language settings and could be a “,” instead of a “.”!

To create a major version, simply click on the Document to highlight it, and then navigate to the Files Ribbon Tab, and then to Publish:

 

You will be prompted to publish the file, and after doing so, should once again be able to save / publish from the Form Editor

 

Let me know if this corrects the error in question. 

 

 

 

 

 

Badge +2

It worked for me  like charm,

you really made my day,

many many thanks.

Are there any other solutions? I’ve tried this approach, but it does not solve my issue.

 

Reply