Office 365 update item permissions error

  • 4 March 2020
  • 1 reply
  • 3 views

The Office 365 update item permissions action is causing my workflow to suspend each time it is ran.



I get this error each time:



Details: ServiceNoResponse



The username is invalid or does not exist, or the password is invalid for the username specified.



In my workflow, I have 6 Run If actions, 2 of which have the permissions actions in them. The other 4 work just fine.



In the 2 Run Ifs, I have two Office 365 update item permissions actions in each. One is configured to allow two users from the current item: [%Current Item: Process Owner%] and [%Current Item: Manager Responsible%] to have edit access. The other is configured to provide the site's default owners group to have design access (this is the same for both Run Ifs). 



The email that should send out is addressed to 2 users from the current item: [%Current Item: Process Owner%] and [%Current Item: Manager Responsible%]. CC'd are [%Workflow Context: InitiatorUserId%] and [%CurrentItem:CC UserID%]. When testing, I set myself as all 3 (current item) users on the form. If I disable both office 365 update item permissions actions, or put the email action before the permissions, the email sends with myself addressed as all 4 users.  



 



Not sure what I'm missing here! Thanks in advance for any help. 



 



 



 


1 reply

Userlevel 5
Badge +17
Does the Knowledge Base article for this error help?
https://community.nintex.com/t5/Technical-Issues/Office-365-Actions-Fail-With-Error-The-Username-Is-Invalid-Or/ta-p/86256

Reply