Known Issue: Unable to search and filter in a list view when using the Date data type
KB003469
PRODUCT
Issue
When using the Quick Search to filter a List view with a Date data type, no search results are returned.
Cause
When you use the Quick Search to filter the List view on a date, the date value you enter is not passed in the same format as SQL expects. The entered date is translated into a "LIKE" SQL statement by the SmartBox service; the data value entered is converted to varchar (text), and no results return because the varchar value does not match the date data type of the underlying column in the database.
Workaround
To work around this issue, enter the date in an ISO 8601 date format such as YYYY-MM-DD, e.g. 2020-01-20 as shown below:

The best practice is to use the Advanced Filtering option, create a new Custom filter, and add one or more conditions to the filter. For example, add two Date conditions (Purchase Date) to the Custom Filter as shown below:
From the Select Filter menu, select the Advanced Query.