Code Fix: Emails fail to send when a generic email address is used in a rule action
KB001949
PRODUCT
Issue Description
After upgrading to K2 4.7, emails no longer send when a generic email address is configured in the from address field on a Send an email rule action in SmartForms.
Cause
The issue was caused by security enhancements introduced in K2 4.7.
Resolution
- Ensure you have K2 4.7 installed.
- Download and install the K2 4.7 May 2017 Cumulative Update from K2 Partner and Customer Portal.
- Get the K2 4.7 May 2017 Cumulative Update FP9 from Regional Support.
- Install the K2 4.7 May 2017 Cumulative Update FP9 to apply the fix.
- Clear your browser cache.
- Add the following entry under the appSettings section in the [INSTALLDIR]K2 smartforms DesignerWeb.config: <add key="Forms.Runtime.Email.RevertToSMTP" value="true"/>
- Add the following entry under the appSettings section in the [INSTALLDIR]K2 smartforms RuntimeWeb.config: <add key="Forms.Runtime.Email.RevertToSMTP" value="true"/>