cancel
Showing results for 
Search instead for 
Did you mean: 

Drawloop - Error: There are no DocGen Packages for you to run for this object based on your profile or role.

Issue

Receiving the error "There are no DocGen Packages for you to run for this object based on your profile or role." when trying to run a DocGen Package

Resolution

In Classic:
Navigate to the Set Security section on the DocGen Package you would like that profile / role / group / permission set to access and move their specific setting over to the Selected Security box on the right. 

In LEDD:
Navigate to the Availability section of the page. See if the user's profile / role / group / permission set is set in the availability.

+++
  • Also check to see if the DocGen Package's starting object is on the object they are trying to run from.
  • It is also possible that they have limited deployment on the "limit deployment" field. Often deployment will be limited to Mass or Web, making the package invisible to single record users and mobile users respectively
  • Check to see if there are filter parameters on the button. See if they match the Filter field on the package
  • See if the button parameter is limiting the list of DocGen Packages by using the ddpids parameter
  • For Community users: check to see if there are any sharing rules on the DocGen Package object

Error Code

Error: There are no DocGen Packages for you to run for this object based on your profile or role.

Labels: (1)
Tags (1)
Version history
Revision #:
21 of 25
Last update:
‎07-08-2020 07:14 AM
Updated by: