Question

Duplicate tasks and emails generated for only one responder

  • 20 December 2022
  • 5 replies
  • 73 views

Badge +1

Hi All,

 

This is related to SharePoint 2016 On Prem (not hybrid), patched to Nov 2022.

We are experiencing an issue with a select number of workflows in a site collection where a list item is created, a workflow starts and processes, however once it gets to the flexi-task, it will generate one task, then about 10-15 seconds later, generate another. it alternates between generating two and four tasks total. this issue also presents when the workflow is manually rerun. some workflows (which contain flexi-tasks) in the same site DO NOT have this issue (yet).

All but the latest task work, with the previous iterations of the task generating a “sorry, something went wrong” page.

 

When checking ULS logs for the correlation ID (from the error page mentioned above), there are three errors that jump out

  1. (<Task URL>): Nintex.Workflow.NWHumanApprovalTaskListNullException: The associated Task List is null (Build: 4630)
  2. Failed to handle form host page on initialize event. Error: Object Reference not set to an instance of an object... at Nintex.Workflow.Forms.ControlTemplates.TaskForm.InitialiseForm(Boolean hasEnterpriseLicense) at Nintex.Workflow.Forms.ControlTemplates.TaskForm.OnInit(EventArgs e)
  3. System.NullReferenceException: Object Reference not set to an instance of an object

 

So far, we have tried:

  1. Republishing the workflows affected
  2. Recreating the workflows affected (from export)
  3. purged workflow history lists
  4. disabling and re-enabling the features at the web and site collection levels.
  5. Upgraded Nintex from the July Release to Nov 16, 2022 Release.

 

Since completing all of the above steps, we have now also observed that all workflows are now taking greater than 10 minutes to change from Starting to in progress, where as prior to this, it would go to in progress upon workflow start.

 

Has anyone experienced this before?

Any assistance would be greatly appreciated.

Cheers,

Rob


5 replies

Userlevel 3
Badge +4

We are experiencing this issue as well with our onpremises SharePoint 2013 Farm. It is the same instance that is  creating the tasks. We have called on Nintex Support to assist and still have a ticket open pending completion of their recommendation to pull actions out of our admittedly large workflow and put them into UDAs. This issue isn’t happening in our non-production farms. 

We’re running Database Version 3.2.5.2

Nintex Workflow 2013 - International (version: 3.5.2.0)

SP patched to June 2019

We have also been getting tickets on workflows taking longer to complete. This began for us back around August 2022 and we opened a ticket with Nintex in late September.

Badge +2

Ive run into the duplication issue when workflows were triggered by other workflows. We ended up throwing in a pause action and set it to 1 min as the first action in any child workflows and it solved our issue.

Badge +1

For us, the problematic workflows are triggered by either list item creation or via triggering from another workflow (breaking a very large workflow into smaller workflows).

Nintex Support also suggested the 1 minute timer, but the next issue we have is that it’s never just 1 minute. right now a pause for 1 minute started at 08:15am and completed at 08:21am… that is not ideal

Badge +2

Yeah…the workflow pauses run on the timer job schedule, so yours probably runs every 5 minutes. It took a bit of education with our users, but now they understand that they won’t immediately get a task when someone clicks a button, but that things are chugging along.  We also had a problem with long pauses(like over 1 hr for a 1 minute pause) when our workflow database was too large(over 10M rows at one point). A couple of solutions for that was to purge the workflow database (either have a farm admin do it via power shell or do it yourself via the purge workflow data link in site settings) and make sure the hide from workflow status box is checked on any large loops to prevent the database from getting exponentially large. 

Badge

Hi, having the same problem here. We tried doing the 1 min pause trick but it didn’t work. Anyone had success doing something else or had an anwser from Nintex Support ? We already have an opened ticket...

Reply