Forms - Multiple Selection Column

  • 3 April 2019
  • 7 replies

We have created a standard SharePoint list with several columns. We have a Category column as well, defined as a Choice column, and set to allow multiple selections.


When creating a new Nintex Form for this list, the Category column appears only as a single select column in the form, and not allowing for multiple selections.


Am I missing something here, or is this a limitation in Nintex Forms for Office 365?

Please advise.

Kind Regards, Frank-Ove


Best answer by andrewg 8 April 2019, 23:38

View original

7 replies

Userlevel 7
Badge +17

It should show check boxes in the at scenario. You could delete the control in the form and add a choices control, then re-connect it to the field, see if it corrects it. Here are the details to its options

Hi Andrew,

Thank you for your feedback and help so far.


I have tried deleting the control, and adding a Choices control. After putting it on the form, I am able to select the Display Format. But once i re-connect it to the "Category" SharePoint column (in the Connected to option, the Display Format disappears, and the control is automatically changed to a dropdown list. Which allows me to only select one item.


BTW: I have tested this in both Responsive and Classic Designer. Same result in both.

Userlevel 7
Badge +17

Ok, i'm going to admit that you found a bug. I'll make sure this gets flagged to support. 


The issue is when you create a multi select column in Modern SharePoint list mode, then the multi select property isn't read correctly.


Workaround: For now, just go to List Settings, select your column to change it's settings and change the setting to Radio Button, click OK, then immediately (from list settings screen) click on the column again and change the setting to Checkboxes (allow multiple selections), click OK. Then open the form by clicking +New for a new item if you have already published the form. It will show the control correctly now, I didn't even have to go to the edit canvas in Nintex Forms and do anything, just jiggle the handle and it was corrected.

Any new column created from List Settings and set to checkboxes mode will be seen that way in the Nintex design canvas. The issue is when these columns are created from the modern mode.

Thanks Andrew,


It now works as expected. 

I just had to "jiggle the handle", and it changed without editing the canvas.


Thank you very much for your assistance.

Hi Andrew


I have used this solution before, however I am however worried that it will remove existing data contained within the column for multiple vales. Is there a workaround that will prevent truncation of multiple records? 


I am in a position that I need to add a new selection to my multiple choice field, however the bug is preventing the field from showing multiple choices within the form.





Userlevel 7
Badge +17
I would contact support then, because you are correct that it could lose data on already created items. I'm sure creating a second column for this wouldn't be much help.

Ok, so my problem is that the form correctly displays the multiple selections in form allowing me to choose them, but then upon the next task action (using a Responsive Task form displaying the column in read only), the workflow clears the selection.  I assume this is also a there another "handle" in need to jiggle?