Solved

Unable to write to hyperlink field

  • 16 February 2024
  • 5 replies
  • 55 views

Badge +5

Hi, I’m updating a list item in Sharepoint from a workflow in Nintex Automation Cloud. The text I’m adding is a url. When I add the hyperlink to a text field it’s fine but when I add it to a hyperlink field it just doesn’t add anything at all - leaves it empty. Any ideas what I’m doing wrong? Full disclosure: I’m including a variable that holds an id in the url.

icon

Best answer by alice_oneill 20 February 2024, 15:25

View original

5 replies

Userlevel 3
Badge +8

@alice_oneill When adding a hyperlink filed you value needs to be the formatted like this 

 

url,text - so the url string then a comma and the text for the link, you can just supply the url . 

Badge +5

Hi Rick, I’ve already tried that and it doesn’t work - it just doesn’t write to the field at all. Do you have a working example I could look at?

Thanks.

Userlevel 6
Badge +22

Hi @alice_oneill,

I have tested this functionality, and it works out of the box.
I just entered a URL and tried using a variable as well, and both worked.
Do you have the same issue with SharePoint designer workflows?

 

Badge +5

Hi @SimonMuntz It’s very strange - I can write the value to a text field but as soon as I try and write to a “Hyperlink or picture” field it just does nothing. And it’s definitely a valid url. I might have to log a call - maybe it’s something to do with our set up. Thanks for replying.

Badge +5

Well - I’ve fixed it. I created a new field and wrote to that and it worked. So annoying! Anyway, this might help someone in the future so thought I’d let you know. Thanks @SimonMuntz for the help :)

Reply