Code Fix: Unallocated worklist items give an error intermittently

  • 16 February 2021
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Code Fix: Unallocated Worklist items present an error

KB002357

PRODUCT
K2 blackpearl 4.7
LEGACY/ARCHIVED CONTENT
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.

 

Issue Description

When you have multiple Worklist items and you open and release one or more at the same time, an error is presented for all unallocated Worklist items.

Error Message

The following error occurs: “26031 All Worklist items {SerialNumber} Allocated for {K2:DOMAINusername} at {IPAddress}”

Cause

Opening and releasing happens in quick succession which results in the instance count going out of sync.

 

Resolution

  1. Ensure you have K2 4.7 installed.
  2. Download and Install the K2 4.7 March 2018 Cumulative Update from K2 Partner and Customer Portal.
  3. Get the K2 4.7 March 2018 Cumulative Update FP7 from Regional Support.
  4. Install the K2 4.7 March 2018 Cumulative Update FP7 to apply the fix.

 


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