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Migrating to new K2 Server caused IPC process error

  • February 16, 2021
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  • Nintex Employee
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Issue

 

IPC processes goes into error and the following error message is logged:

"1 Send failed with error: An existing connection was forcibly closed by the remote host."

 

Diagnosis

 

  • "Workflow Server" and "Workflow Management Server" fields in the Environment Library and String Table are configured correctly to new server.
  • New sub workflows can be started without any issue.
  • Only process instances that are started before the server migration may experience this issue when attempting to start sub workflows.

 

Resolution

 

Update IPC records that are pointing to the old server to point to the new server:

 

1. Backup the K2 database

2. Run the following query in the K2 database to retrieve the affected records.
 

SELECT *FROM [Server].[IPC]WHERE [DstServer] = 'Old Server'SELECT *FROM [Server].[IPCReturn]WHERE [DstServer] = 'Old Server'


3. Run the following to update the IPC records. Make sure to replace the values accordingly.

UPDATE [Server].[IPC]SET [DstServer] = 'New Server'WHERE [DstServer] = 'Old Server'UPDATE [Server].[IPC]SET [DstConStr] = 'Integrated=True;IsPrimaryLogin=True;Authenticate=True;EncryptedPassword=False;Host=<New Server>;Port=5252'WHERE [DstConStr] LIKE '%Old Server%'UPDATE [Server].[IPCReturn]SET [SrcServer] = 'New Server'WHERE [SrcServer] = 'Old Server'

 

4. Restart K2 service

5. Retry the process in Error Profile

 

Note: Please involve a Senior Engineer/Developer for these steps as further issues can occur if it is not followed correctly.

 

 

 

 

 

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