Skip to main content
Nintex Community Menu Bar

Code Fix: An error occurs when executing a Salesforce SmartObject

  • February 16, 2021
  • 0 replies
  • 6 views
  • Translate

Forum|alt.badge.img+5
 

Code Fix: An error occurs when executing a Salesforce SmartObject

KB002408

PRODUCT
K2 Five 5.1
K2 Five (5.1) Fix Pack 1

 

Issue Description

An authorization error occurs when executing a Salesforce SmartObject. If the SmartObject was executed via an activity in a workflow, the workflow will go into an error state.

Error Message

The error message states: “OAuth token is expired and requires reauthorization”.

Cause

This occurs due to the service account not having a token.

Resolution

  1. Ensure you have K2 (5.1) installed.
  2. Get the K2 Five (5.1) FP1 from Regional Support.
  3. Install the K2 Five (5.1) FP1 to apply the fix.
The service account will now be assigned a token during feature activation of the Salesforce feature.

 

Did this topic help you find an answer to your question?

0 replies

Be the first to reply!

Reply


Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

 
Cookie Settings