cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Conditional Start Workflow Not Starting

Jump to solution

 I have a very simple workflow which sends out an email when an item is modified.  I have a Conditional Start setup to run when items are modified.  Workflow ran once, but will not run again.  Tried on multiple different items.  Condition is looking at a Choice field where options are 'yes' or 'no'.

This is currently the only workflow on this list that is enabled to run.  Any ideas what could be causing this to not initiate?  I did remove the conditional start and had it set to run when item is modified, and that worked.  Put the condition back in and will not auto-initiate anymore when items are modified to meet the condition.

Thank you.

Labels: (1)
Reply
13 Replies
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

Perhaps you could find some clues here >>>  

0 Kudos
Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

Good Morning Fernando,

Thank you for that reference, but I had already read through that before posting my question.  That post is not applicable to what I am doing.  I already have my workflow to start conditionally when my 'ReadytoBuy' Choice Field equals 'Yes'.  I do not have any site workflows, just a simple workflow that will send out an email when an end user selects 'Yes' for the Ready to Buy question on the form.

I have used conditional starts on both New and Existing items in previous workflows on other lists.  Why now, all of a sudden, with this list, is it not working?  What causes Nintex Workflows to act differently?  Is this not a stable environment/system that can be trusted to work the same every time?

Thank you,

0 Kudos
Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

Update

I deleted the workflow, and recreated a new one in hopes to try and get it to run for the conditional existing start.  The new workflow is now not showing up in my 'Modify View' available columns.  It appears the situation is getting worse, as it is now no longer recognizing my new workflows and adding to the column settings.

Being able to have workflows start conditionally when items are modified is a huge necessity for my organization.  Additionally, being able to add the workflow to the view so we can see if it successfully runs is also important.

Thank you.

0 Kudos
Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

Hello,

Can you create a new view on the same list and see if the workflow column becomes available there for display?   

Thanks

Mike

0 Kudos
Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

The workflow is based off an all items default view.  I got around it by running when an item is modified, then having a Run If to determine if the Ready to Buy field is 'Yes'.  If it's 'yes', it will send out an email, if it's no or blank, if will just end the workflow.  This is not the best route I'd like to go, but I do not have a lot of time testing and creating new views...The workflows should always work the same...the amount of inconsistencies with Nintex is becoming quite the nuisance.

0 Kudos
Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

try to apply for both conditional start and status column following procedure (one at a time):

1. remove starting condition/uncheck 'Create workflow status column' option (make sure you really remove condition in a extra dialog, not just set conditional start to NO on main dialog)

2. publish workflow

3. configure new starting condition/check 'Create workflow status column' option

4. publish workflow

 

both problems should recover.

0 Kudos
Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

Tried that, didn't work.

I will be going back to what I just had that did work.  Start when items are modified, then have a Run If to check if the Ready to Buy field is equal to 'Yes'.

I feel this is definitely a Nintex Bug.

Thank you.

0 Kudos
Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

I'm experiencing the same issue across the tenant. All the workflow that had conditional start when item was modified, have stopped and are not triggering. This is impacting a large group. I have created the case but have not heard anything back yet.

Nintex Support‌, please provide an update if you know this is an issue.

Reply
Workflow Hero

Re: Conditional Start Workflow Not Starting

Jump to solution

Huh, I haven't experienced this, but have heard it from a few people now.

Throwing the Bat Signal up... Rick De Marco‌  Vadim TabakmanJonathan Butler

0 Kudos
Reply