pkempf
Nintex Newbie

Show/Hide (with rules) rendering issues

Jump to solution

Hello,

Having lots of problems rendering forms with Show/Hide rules.

I have three basic fields - one Single Line textbox for Name, and two date fields for Start and End date.

The fields are hidden to start with, and when you select a checkbox, it shows the fields.  However they jump all over the form.  I've checked that the Rules are in the same order as the fields on the form, with no luck.  I've tried putting them in panels with no luck.

(Design screen)

Design Screen

(No checkboxes selected, fields hidden)

Fields Hidden

(Checkbox selected - fields not rendering correctly)

Fields shown - rendered incorrectly

Hope someone knows how to fix this.

Regards,

Peter

0 Kudos
Reply
2 Replies
bashyarajan
Nintex Newbie

Re: Show/Hide (with rules) rendering issues

Jump to solution

Hi Peter,

         This seems like you have placed the controls in different panel controls. I would suggest you to place all the 3 controls  inside same PANEL CONTROL and then apply rules for that panel control. This should work.

View solution in original post

Reply
pkempf
Nintex Newbie

Re: Show/Hide (with rules) rendering issues

Jump to solution

Cheers Bashya.  

I had them in separate panel controls the first time and didn't work, but seems after putting them in separate panels and having only one rule per panel, they seem to render correctly.

I needed three panels as the combinations could be

1) Name of Employer / Start Date / Finish Date (for Work Experience / Agency Staff / Consultant or Other)

2) Start Date (for Permanent Staff)

3) Start Date / Finish Date (for Public Service Staff)

Reply