Not applicable

Nintex form appears without control borders on display mode

Jump to solution

I have a new mode Nintex form that collects data for leave request and on submission, a workflow is triggered to assign a task to the approver. When the task is clicked on, there is a link to view the form on display mode, where only the text on the form appears without any borders for the controls (I mean no text box borders). It looks plain. Anyway to make it look like the original form ?

Tags (3)
0 Kudos
Reply
4 Replies
andrewg
Automation Master
Automation Master

Re: Nintex form appears without control borders on display mode

Jump to solution

When you are in display mode there are two controls added when the form is rendered. You will have to modify a few CSS classes to accomplish the changes you seek.

For example, when in display mode, my Title field now has an extra <div> with the value within it. The actual INPUT control is set to hidden. Since this is a new control, the borders and white background while in edit mode are not seen (because the input control was hidden).

<div class="nf-filler-control-inner">

<div class="ms-rtestate-field">My Demo Item</div>

<input name="ctl00$ctl33$g_846ae77e_d400_4681_a5e1_1284400d8e73$ctl00$ListForm1$formFiller$FormView$ctl18$ctl02" type="text" value="My Demo Item" disabled="disabled" class="aspNetDisabled nf-hidden-associated-control" style="visibility:hidden;" formcontrolid="99b4c39b-323b-418f-a987-9d5cab30e572">

</div>

So if you change the style for ms-rtestate-field then you can make the background white and add borders. Put your changes in the Form Settings under Custom CSS.

View solution in original post

Reply
andrewg
Automation Master
Automation Master

Re: Nintex form appears without control borders on display mode

Jump to solution

Or, to have a lot of fun with it. You could configure each control in the form, in the advanced section set the Mode to Edit. Then in the Appearance section, set Enabled to Expression. The expression is set by using the reference icon and add "fn-Or(Is Edit Mode,Is New Mode)"

0 Kudos
Reply
mindymac03
Nintex Newbie

Re: Nintex form appears without control borders on display mode

Jump to solution

If it's a multi line textbox, go into the List Settings and select that column. Under "Specify the type of text to allow:", change it from "enhanced rich text" to either plain text or rich text. Then the border will appear.

Reply
Clipper
Nintex Newbie

Re: Nintex form appears without control borders on display mode

Jump to solution

@andrewg wrote:

Or, to have a lot of fun with it. You could configure each control in the form, in the advanced section set the Mode to Edit. Then in the Appearance section, set Enabled to Expression. The expression is set by using the reference icon and add "fn-Or(Is Edit Mode,Is New Mode)"


Wow ! Now THAT is awesome. Until I found this post I was very unsatisfied with the Display Mode with a common background color which means if you don't have borders you can't distinguish labels and contents. I was trying to play with CSS and ms-rtestate-field but it does not work for all field types.

 

Your solution is very elegant as the form looks exactly the same in display than edit, except the fields are not enabled. Love it.

0 Kudos
Reply