Nintex RPA import Data from Excel an issue

  • 2 September 2021
  • 8 replies


please help, I have an issue with importing data from the any Excel file. I use: Data - Open Data.., after preparing the data using the data import wizard, I get the following issue: "OleDbConnection is Null OR Closed."




Best answer by DmitryR 19 October 2021, 08:55

View original

8 replies

Userlevel 2
Badge +9

Hi, Dmitry,


Please try updating your Access database engine. Go to and download the 32-bit version. Then install it using the /quite flag "accessdatabaseengine.exe /quiet" from an administrative command prompt, and let us know if that fixes the error you're seeing.




We are using 64-bits system only and can't change it. Do you have other solve? Does Nintex RPA works with 32-bit MS Access only?

Userlevel 2
Badge +9

Foxtrot is a 32-bit application that uses a helper app called Foxtrot64 to do interaction on 64-bit systems. That said, we need the 32-bit version of the Access database engine, and that should be installable on your system. Let me know!

OK. I understood. Unfortunately, this is not suitable for our client.

Userlevel 2
Badge +9

Keep in mind that the installation of Nintex Bot already installs this 32-bit component and this is simply an update of that component to determine if it solves the issue you're experiencing.

The client has updated the MS office including the "Microsoft Access Database Engine 2016 Redistributable" component, but it didn't help. 


Please try installing Access 2016 Redistributable again but first uninstall the currently installed version (listed as 'Microsoft Access database engine 2016' in the 'Apps & features' list).  This is because the latest version will not install properly over an existing older version of Access 2016 Redistributable.  It must first be manually uninstalled.

When installing the 32-bit version on an operating system that already has a 64 bit version of Office already installed on it, it must be installed through a command prompt (Run as Administrator) using the /QUIET option.

For example:

If you downloaded the installation file in the folder:

Run the following command in the Command prompt: C:\Windows\System32> C:\Temp\AccessDatabaseEngine.exe /QUIET


You will not see any prompts during installation.  After a few minutes, check to see if it has been installed in Windows 'Apps & features' list.


Thank you

This issue is related to the Russian language for the Window system. We are using a workaround - switched the system language to English.