Solved

Insert Username into Active Field


Badge +2

I am trying to create a wizard to log in to a site but when I try to set up the command ‘insert username into active field’ I get an error message.  Do you know what I could be doing wrong?

For Step 1, the process of launching the website is working.  The cursor is positioned in the User ID field.

For Step 2, I try to drop the insert username command and choose the specific user for the site, but I get an error message:

The following commands are not supported at this position and will be removed: 

Insert username into active field.

icon

Best answer by bsikes 27 March 2024, 16:28

View original

14 replies

Userlevel 4
Badge +10

Is Step 2 targeting an application (like a browser) or is it just an Advanced Command step? 

Badge +2

Step 2 is an Advanced Command step.

Userlevel 4
Badge +10

That might be the problem.  Try changing the step to target the application you actually want to insert the username into. 

 

Advanced Commands seem to be annoyingly picky, in that they assume if your doing a command that interacts with something (like this one I assume), that your doing it in the step’s targeting application. If there’s not a targeted application (like an advanced command step), then it assumes it doesn’t have all the information to correctly identify where the command should interact. 

 

I think that’s the case here, which is especially annoying since the “Insert Username into Active Field” command assumes the field is already active.

Badge +2

Thank you for responding…..  Step 1 has the Set URL and Open URL commands.  Then I added another one for Control Window State, that I hope maximizes the window.  From Normal view I have two Advanced Commands.  I don’t know how to ‘change the step’.  If I have step 2 active and click on record I get a message ‘this action will override all existing…….’.  Is this how I change the step?

Userlevel 4
Badge +10
  1. Get the application you want to target for step 2 up.
  2. From the normal view, Click step 2 to select it
  3. Click Append Recording at the top
    1.  

  4. Click into the field you want to target in the application
  5. Stop recording
    1. At this point, you’ll now have a 3rd step that is clicking in that application
  6. Optionally, remove the “Click” action by right clicking it from the right hand pane, and choosing delete
    1.  

  7. From the advanced commands view, move the advanced command to insert the username from your advanced command step, into the “Step end” section of the newly recorded step
    1. You may need to change the “Step End” section to be “Advanced Commands” instead of go to next step

 

Badge +2

oh, my, you are very helpful.  When I tried to record the action, I received a message that I need to have the Admin add the application and record again.  I will get this done and try your notes.  You could never imagine how much I appreciate this.

Userlevel 4
Badge +10

Not a problem! It’s not an intuitive process! 

 

In case it’s an issue (this was for me last week!), when they’re adding the new application through Nintex Admin, they’ll need to remember to then allow the catalog (folder?) your making your Wizard in, access to that newly defined application. Otherwise it will keep saying you need to define it. 

Badge +2

Oh, how I appreciate you!!  I will share this with them as well!

Badge +2

I am trying to create a wizard to log in to a site but when I try to set up the command ‘insert username into active field’ I get an error message.  Do you know what I could be doing wrong?

For Step 1, the process of launching the website is working.  The cursor is positioned in the User ID field.

For Step 2, I try to drop the insert username command and choose the specific user for the site, but I get an error message:

The following commands are not supported at this position and will be removed: 

Insert username into active field.

I am trying to create a wizard to log in to a site but when I try to set up the command ‘insert username into active field’ I get an error message.  Do you know what I could be doing wrong?

For Step 1, the process of launching the website is working.  The cursor is positioned in the User ID field.

For Step 2, I try to drop the insert username command and choose the specific user for the site, but I get an error message:

The following commands are not supported at this position and will be removed: 

Insert username into active field.

Check this document:
https://help.nintex.com/en-US/kryonrpa/22.9.1/Content/AdvancedCommands/CredentialsVaultCommands/Insert_Username_Into_Active_Field.htm?Highlight=insert%20username

Badge +2

Thank you for sharing Zakirkhan.  I was able to find that document but I could not get it to work.  I am still new to this process.

Badge +2

Do you ever have any issues with your F11 key making the full screen instead of stopping the recording?  Is there a trick to that?

Badge +2

Initially I was working with Edge, because I thought we had to use that in order for the software to work.  Edge would not allow me to record so I am now trying to use Chrome.  It has allowed me to record the step you mention above, go to Step end, as you illustrated, then ‘When ends’ is changed to ‘Advanced commands’.  I can add the Into the active field type the specific user / password.  When I change to Normal view, I have a couple errors:  1) Insert username selected application doesn’t match current step  2) Insert password selected appliction doesn’t match current step.

Userlevel 4
Badge +10

Edge should work, but maybe the extension is disabled?

 

 

For the credentials, do you know if the credentials setup within Credential Vault are for the application you’re targeting? 

Badge +2

Thank you for responding!  Hope you are doing well!  I was able to finally figure out the name of my credentials had to match the title of the application.  🙄  I am now beyond that point; my credentials are logged in the web app and I am trying to get the data out of excel into the field within the app.  It’s a big learning curve!!  You really have been very helpful :)

Reply