Question

Unable to Save - Object reference not set to an instance of an object

  • 12 December 2022
  • 8 replies
  • 929 views

Badge +2

On the new responsive design, we started getting the error Unable to Save - Object reference not set to an instance of an object since last friday ( 09 December 2022).

We tried creating a new task list for the new workflow and the error is resolved.

However. we have many workflows already running which are using the “Workflow Tasks” list and it seems that the existing tasks too started failing upon submission with same error.

What is the root cause of the error and what can be done to fix the existing inprogress workflows?

 


8 replies

Userlevel 6
Badge +16

Hi @vikaskottari 

 

Referring to this thread

The suggestion is to

  1. create a new Workflow Task List
  1. Set the workflow Task list to use the new ‘Workflow2 Task’  

 

 

Hope that helps

Badge +2

Hi @Garrett ,

Thank you for the reply.

I am aware of this solution. But this is not helping me.

I have many workflows currently inprogress and users are unable to approve and submit the task form. 
Also, what is the root cause of this issue?

Userlevel 6
Badge +16

Hi @vikaskottari 

How many items are in your Workflow Task? 
Has it exceeded the List View Threshold limit of 5000 items in SharePoint Online?

There is also the possibility of the List being corrupted.

Badge +2

Hi @Garrett 

workflow task list has around 3500 items. 
what do you mean by List being corrupted? How do we know if it is corrupted or how to fix it?

Userlevel 6
Badge +16

Hi @vikaskottari 

Its better if you log this issue with Nintex Support (I’m sure you have already done so) and get their advice or suggestion on how to proceed.

 

 

 

Badge +2

Thank you @Garrett 

Userlevel 5
Badge +15

This has happened to us in the past and I could never figure out the issue. 

It’s now happening again. I have a ticket in, but doubt anything will come of it. We have 1,960 items in the list. I don’t know what to do. We were NOT ready to move this one to NAC but without knowing what the issue is, it’s hard not to move into NAC.

Userlevel 6
Badge +22

In my experience this issue occurs for one of two reasons.
Firstly it is because the task list has been altered in some way.  It could be a setting on a column or new columns added or removed etc.  A workflow has been running on the task list and it has altered columns.
The Nintex task content type has been altered.
The other is that the list has somehow become corrupt in SharePoint.

Reply