How to fix format for Document Generation?

  • 19 June 2017
  • 4 replies



I am trying to get my PDF formatted the right way. On the picture you can see on the left, how it should look like (screenshot from Nintex Forms) and on the right the output from Nintex Document Generation. 


Wrong formats in the generated PDF


For the date field, I already tried various options that are available within the Nintex Document Tagger. But the options available do not fit my requirements.


Has anyone an idea? Or is this a current product restriction?


Thanks for your support,


Best answer by rickdemarco 29 June 2017, 01:11

View original

4 replies

Badge +8

Hi Dom,

When using a date field and selecting a format within the tagger unfortunately it will always add the time to the end which is obviously not what you want. Having said that there is a workaround which does require an extra action in the workflow, this is how you can do it:

  1. Add a new text variable for each date field you want to add to the pdf
  2. Add the Set Workflow Variable to set each date field to the text variable
  3. When setting the variable use the Advanced Lookup option, select List Lookup (I assume your date is coming from a column), select your Date field and click the fx button and from the popup select 'Short Date'
  4. Repeat for each date field
  5. Open the tagger and instead of adding the list column add the new variables.

Let me know how you go..

Cheers, Rick

Hi Rick,

Thanks! This worked perfectly for my case

Have a nice weekend,

Userlevel 4
Badge +8

Rick De Marco - what about the currency formatting mentioned by Dominik above?  

I am having this same problem, where I have many SharePoint currency columns set to use 2 decimal places.  But when these are output via document generation, they end up with only 1 decimal place for example, "2000.00" is rendered as "2000.0".  Note that does not occur if the 2 decimals are non-0.  For example a value of of "2000.98" is rendered properly in Doc Gen as "2000.98" and a value of "2000.50" is still rendered as "2000.5".

I know as a work-around I could do the same thing that you suggested for the dates... that is save the number to a text based variable and reference the variable in Doc Gen instead of the source item property.  But I'd prefer to avoid creating lots of additional text variables unless I really need to.

Please advise.


Tom, did you ever find another solution?