Form Error: Invalid text value

Userlevel 5
Badge +13

Ok, I'm stumped on this and I'll try to give as much information as possible. We are in Office 365 and have been able to recreate this issue in Chrome as well as IE.


We have a form that has the following fields:

  • Title - single line of text. Default value is ARC Meeting: [Todays Date]
  • Meeting Date - default value is today's date/time
  • Scribe - people picker, default value is current user
  • Facilitator - people picker
  • Attendees - Multi-select choice (checkboxes)
  • Additional Attendees - People picker that allows multiple selections
  • Agenda - Multi-line rich text
  • Discussion Items - Lookup to other list on this site that allows multiple selections
  • Meeting Minutes - Multi-line rich text
  • Action Items - repeating section
    • Item - single line of text
    • Responsible User(s) - people picker that allows multiple selections
    • Goal Date - date field (no time)
  • Attachments


There are Save as Draft, Cancel, Save and Submit buttons.


The Problem:

When some users submit sometimes (not consistent) they receive the following error: 



I have no validation occurring anywhere; no JavaScript, no rules, nothing. Also, no field is highlighted when this error appears. 4 people all with the same permissions (in the same AD administered group) all get a different result, even when using the same browser. I did have some Javascript in the form, one piece checking the checkboxes by default on a new form and one piece forcing attachments to open in Office Online. I removed all JS and still have this problem, again, intermittently.


Progression of events:

  • I tested the form, had no problems, rolled it out
  • First user tries to make a submission, receives this error. When this error happens, all his formatting is removed from the rich text fields. Check user permissions, seem fine. Have another user in the same group submit with no issues. Come back to this user, try to have him submit a blank form (there are no required fields), receives same error. User is eventually inexplicably able to submit. I am still unable to recreate the problem with my credentials.
  • Another user says they have the same issue. I mention the Javascript, he disables UBlock add-in, and is able to submit.
  • Third user has the problem: I remove all Javascript from the form. User can now save as draft. Later mentions she still cannot "Save and Submit."
  • Today, revisiting the issue with the third user, she submits the form several times, each time adding something (ex, only title the first time, second time title + date, third time title + date + scribe, etc). Is unable to submit after adding "Discussion Items." We realize that one discussion item has an ampersand in it (title of a request in another list). Once removing that discussion item, user is able to submit.


These chain of events don't seem to make total sense. User 3's problem can't be the same as user 1's since user 1 couldn't even submit a blank form. Thoughts? Things don't seem to 100% add up unless I'm missing something.


Best answer by andrewg 12 May 2017, 21:57

View original

9 replies

Userlevel 5
Badge +13

I think we've cracked it! It seems to be due to the fact that the Lookup is connected to a single line of text column on which the character limit is being exceeded. But, I need that Lookup info for workflow, and you can't link it to a multi-line field, even if it's plain text. So, ideas on working around this? I was trying to get the values via Javascript and hide the multi line field, but no dice so far.

‌, ‌, ‌, ‌, ‌, ideas?

Userlevel 7
Badge +17


I just have one additional question - does this error occur when form is opened in modal window, or as well as a full screen?



Userlevel 5
Badge +13

This is when it is full screen. I haven't tried it in a modal window.

Userlevel 7
Badge +17

Is the lookup source data in a SLT? How can the character limit be exceeded?

Userlevel 5
Badge +13

The lookup is a Nintex form control that looks up a particular view of another SharePoint list. You can connect it to a column to store the selections someone has made, essentially. The only type of column it will allow you to "connect" to is a single line of text which has a 255char limit. Since the list the lookup is referencing can have some somewhat lengthy titles and people can choose many, when it tries to store the selected items in the single line of text field (ex thing1,thing2,thing3,thing4) the character limit can be exceeded. 

I can't just leave the data in the lookup control, however, it needs to be in a column so that I can act on it with workflow. I haev a workflow, that when the item is saved (these are meeting minutes) it looks at the lookup selections (which are "requests" or topics) and on each of those requests, it writes a link to the meeting minutes that were just saved so that people can open a request and go straight to any meeting minutes that discussed it.

Userlevel 7
Badge +17

Here's a strange idea. What if the lookup control isn't connected to a column. Then use Form data to parse into a MLT or collection?

Userlevel 5
Badge +13

This was it! Perfect! Thank you so much. Here's what I did:

  • Name the lookup control on the form
  • XML query on the form data for //lookupData
  • It stores that in a collection, so I get the item from the collection and put that to text, now I have a string of IDs essentially, like this: 2;#;#3;#
  • Do some replaces to get it to 2;3 etc
  • XML split at ; to get a collection of IDs
  • Do the normal forEach stuff I was already doing except using these IDs!
Userlevel 7
Badge +17

Sweet! Didn't know if that would solve all the problems. Thanks for providing the full solution!!

Userlevel 1
Badge +9

I was wondering if you would be willing or able to describe a little more what you did here.  I'm having  a similar problem with a Sql Request control.  The possible selections are fairly lengthy and the user wants the ability to use a multi select check box.  Problem hits when I go over the 255 character limit the form crashes when they you hit save.  What control did you use to do a xml query on the form data?  I've only known to do xml queries as part of the workflow.  Unfortunately the form will blow up before I can get the workflow started.