SharePoint Online "Update items" action fields not updated

  • 18 November 2022
  • 4 replies

Badge +3


I'm using the SharePoint Online "Update items" action. If I add or remove fields on the source list, those changes aren't immediately reflected in the fields available in the action.

I tried closing the workflow, recreating the action, deleting the workflow and starting again. Nothing seemed to work at first, but eventually the fields did update.

Is this just a timing issue? If so, how long do you have to wait? Or, is there something you can do to update the fields?

Thank you for any advice.


Best answer by WouterT 18 November 2022, 12:22

View original

4 replies

Userlevel 3
Badge +9

Thanks for posting. A well-known issue for most of us.

From my personal experience:

If I update a list (additional field for instance) while editing a workflow I do the following:

  1. SAVE the workflow

  2. Press Ctrl-F5 to refresh the workflow editor

  3. Click the first action where this object is used. This will refresh the object definition.

Then your newly defined field will show up.

Userlevel 3
Badge +8
Hi, if your workflow starts with a SharePoint online event, you can remove it and re-insert your configuration settings on the start event action (That usually updates new fields/columns from SharePoint). If not, you can try and re-create your connections & data sources.

Hope this helps 🙂
Badge +3

Thank you for your quick response! I will try that.

Badge +3
This worked for me too. Thank you very much.