Unable to create/open/edit workflows in K2 Designer

  • 16 February 2021
  • 0 replies
  • 44 views

Issue

Unable to create/open/edit workflows in K2 Designer after the K2 Database has been migrated to a new database server

 

19860i00C3742735FFCD7F.png

 

Error Code

Something went wrong on our end, and the workflow designer needs to close. Please try your action again. If the problem persists, contact your administrator.

 

Diagnosis

- Able to create workflow instances on those existing workflows

 

- The Error appears after loading the page 80%

 

-  The K2 service account has the proper rights given in your K2 server and from the DB

 

-  The K2HostServer.exe.config file and Server.setup file has the correct DB specified

 

-  The below error is seen from the hostserver log and the events log

 

Error processing message from 10.14.4.132:50592: Authentication With Server Failed : The server principal 'insert K2 service account here' is not able to access the database 'K2' under the current security context.

 

- The old K2 database is still mentioned in the web.config for the path [K2 install drive]K2K2 smartforms DesignerK2 workflow Designer

 

Resolution

1. Create a backup of your web.config  under the path "[K2 install drive]K2K2 smartforms DesignerK2 workflow Designerweb.config" and save it to another folder outside of K2

2. On the web.config look for the key word

connectionString="Data Source

3. Update the datasource to use the new DB that you have

4. Once done save the file

5. Do an IISRESET

6. Clear the web browser cache

7. Test again

 

 

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