SmartObject created using SQL table not visible in K2 designer workflow


Hello Everyone,

 

In one of my K2 for SharePoint application I have created Smartobject using sql table, but the smartobject is not visible in K2 designer workflow.

Any help is appreciated.

 

I am using K2 Blackpearl 4.7 and K2 for SharePoint

 

Thanks,

Prafull

 


3 replies

You have to allow smart obejct to be used in workflows when buiding workflow in designer. In designer go to the smart obejct and edit it. On the general tab at the bottom is a checkbox, "Allow this SmartObject to be used in Workflows". Check this and save the smartobject. Dont make other edits especially on SharePoint objects.

 

You have to close and reopen worflow and it cna take a few minutes to show up. If you find it is already checked but not showing up then uncheck and save then go back in and check the box again and save.

 

Hope this helps

 

Yes, I was already having check box check. I tried unchecking and checking but didnt worked.

Hi,


 


 


The SmartObject might need to add to SmartObjects page, see below.


1) Navigate to SmarObjects page from the K2 for SharePoint app.



2) Add the SmartObjects under Additional section.



 

Reply