cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Failed to run Workflow and Failed to Publish [Urgent]

Jump to solution

I am receiving the below error message after clicking on Publish

 

soapSmiley FrustratederverServer was unable to process request. ---> Failed to publish workflow: <Error><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" Column="-1" Text="Type System.CodeDom.CodeTypeReferenceExpression is not marked as authorized in the application configuration file." /><CompilerError Line="-1" ...

 

 

Also, workflow "failed to Start".

 

Kindly advise what is the reason of this issue.

Labels: (1)
0 Kudos
Reply
3 Replies
Highlighted
Nintex Employee
Nintex Employee

Re: Failed to run Workflow and Failed to Publish [Urgent]

Jump to solution
The environment has been updated with Microsoft CU's that break the workflow engine.

Here is Microsofts fix:
https://blogs.msdn.microsoft.com/rodneyviana/2018/09/13/after-installing-net-security-patches-to-add...
Reply
Highlighted
Nintex Newbie

Re: Failed to run Workflow and Failed to Publish [Urgent]

Jump to solution

Please find attached details of the updates installed on the Sharepoint servers:

Note: both servers have different update patches.

 

 

0 Kudos
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Failed to run Workflow and Failed to Publish [Urgent]

Jump to solution
Regardless of the updates the error still remains and the only way to resolve it is to update the web.config files as per the blog linked above.

View solution in original post

0 Kudos
Reply