hagarm
Design Dabbler

How to ignore Decision validation when save button clicked in Flexi Task Nintex Form

Jump to solution

I have a Flexi Task in my workflow that uses a Nintex Form.  The Decision field contains the outcomes.  But I also have a separate status field that I want to allow an approver to mark as 'In progress' so the rest of the group doesn't start work on that task.  I thought the Save  button would allow for this when 'Causes Validation' is set to no , but it gives a validation error on the decision field.  Does anyone know a way around this? Does the Causes validation setting not work this way?

Reply
9 Replies
kapilkjoshi
Automation Master
Automation Master

Re: How to ignore Decision validation when save as incomplete button clicked in Flexi Task Nintex Form

Jump to solution

Hi ,

I'm not sure what is "Save as Incomplete" button. could you check the configuration for its type, whether its Save, Save and Submit, Javascript? Past some screen shots here.

Expand the Advanced section. There is an option called Causes Validation. If you select No, then the button will just save the form without validating the fields. Is that what you are looking for?

Reply
hagarm
Design Dabbler

Re: How to ignore Decision validation when save as incomplete button clicked in Flexi Task Nintex Form

Jump to solution

Sorry, yes I am referring to a 'Save' button.  I forgot that I just changed the button label to 'Save as Incomplete'.  I have it set to Causes validation = No like below:

When I attempt to save the form using the 'Save' button (or Save as incomplete) I get a validation error:

Reply
kapilkjoshi
Automation Master
Automation Master

Re: How to ignore Decision validation when save as incomplete button clicked in Flexi Task Nintex Form

Jump to solution

I see. If Approval is mandatory field, then you have to select 1 value before you can click on Save. Cause Validation set to No will skip any validation rules you may have created. Sorry for misunderstanding.

So here is the way then, mark approval field as not mandatory in the list. This way it will be saved when you click on Save as Incomplete. 

Create validation rule on this field like=  Is empty({self}), show some message. 

This validation will occur on "Save and Submit" button where Cause Validation is set to Yes. Will that help?

Reply
hagarm
Design Dabbler

Re: How to ignore Decision validation when save as incomplete button clicked in Flexi Task Nintex Form

Jump to solution

Unfortunately, I am not having any luck.  This is a Nintex form for a WorkflowTask list item.  The field appears to be set as optional in the list.   But when I click the Save button, it still seems to validate.  I can make the decision field  'not connected', then no validation is done.  I also tried, with no success to setup a validation rule usingFormula Builder isNullOrEmpty({Self}), but that seems to validate no matter which button I press, Save or Save and Submit.

Reply
kapilkjoshi
Automation Master
Automation Master

Re: How to ignore Decision validation when save button clicked in Flexi Task Nintex Form

Jump to solution

Hi Michelle Hagar,

Sorry for delay in responding but i don't think its achievable what you are requesting with a Save button. Sorry for misleading answers earlier.

The Cause Validation part is used for any Javascript validation that you have customized and not for the standard submissions. There is no way to simply save the values in the form and not cause validations. Outcome is a required field when responding to tasks.

You can try creating new Task Outcome field and then create a new site content type based on the Nintex workflow task. This will allow you to leave the field as non-mandatory when clicked on Save as Incomplete button.

Then using custom Javascript validation, you can validate this field on Submit. See the blog here:  

Hope this helps.

0 Kudos
Reply
xMikeX
Automation Master
Automation Master

Re: How to ignore Decision validation when save button clicked in Flexi Task Nintex Form

Jump to solution

Hi Michelle,

A simple solution that many use to solve this problem is to add another choice to the Decision control itself such as "In Progress", this way when you use the save button, it should stop the workflow from moving forward as well as allow you to pass validation.   Then you would use a Save and Submit button to move the workflow forward.

Thanks,

Mike

View solution in original post

0 Kudos
Reply
hagarm
Design Dabbler

Re: How to ignore Decision validation when save  button clicked in Flexi Task Nintex Form

Jump to solution

I initially tried this, but I thought the workflow would try to continue.  It doesn't, if only the save button is selected.  So I'm trying to disable the Save and Submit button if decision=='In Progress'.  I've tried it many different ways, and it doesn't seem to work.  Do you happen to know of a trick with rule expressions using Choice fields?

0 Kudos
Reply
hagarm
Design Dabbler

Re: How to ignore Decision validation when save  button clicked in Flexi Task Nintex Form

Jump to solution

I got it!  I had to use the value of the decision field.  It was set to a nbr.  For anyone else struggling, either check your form using the designer tools/firebug/etc to get the value.  Or you could create an calculated field that shows the value of the decision field.  This will show the number assigned to each choice within the decision field.  Thanks to you both Mike and Kapil!

Reply
Not applicable

Re: How to ignore Decision validation when save button clicked in Flexi Task Nintex Form

Jump to solution

Hi Can you explain a little deeper on this solution??

0 Kudos
Reply