Workflow variable in task form not populated

  • 22 December 2017
  • 3 replies

Badge +8

Hi guys, 


I am working with Nintex for Office 365 and what I want to achieve is that an approver of an approval task can fill out a field on the task form of type "People". In the workflow I need to use the person that was provided. 


I have tried two scenario's:

  • Adding a person or group field to the Tasks List to all content types. The field does not show in my task form editor window in the Task Columns category nor within the "Connected to"-section. Also not after saving/refreshing my window.
  • Adding a workflow variable of type string which I connected to the People field on the form. When filling out the form and logging the contents of the variable afterwards in my workflow, it remains empty. 


Anyone having the same issue, or did someone get it working or maybe has a different solution? 

I am using Nintex responsive forms (and I would like to keep it this way as currently all my other forms are built in the responsive forms builder as well).


Kind regards, 



Best answer by glenda 9 January 2018, 12:00

View original

3 replies

Badge +5

Hi ‌,

Have you tried Edit Task Form in the Task action inside the Workflow Designer?

Badge +8

Hi ‌, 

Yes, I am editing the task form trough "Edit task form" from the workflow designer window in my start a task process action.

Best regards, 


Badge +8

Guess I am not getting it solved on an already available content type.

The following workaround seems to do the trick, but creating a new content type is necessary:

  1. Create new content type through site settings (inheriting from Workflow Task). Create the site columns you need as well. 
  2. Add the necessary site columns to the content type.
  3. Add the newly created content type to your workflow tasks list the workflow is using. 
  4. Go to your approval action (or create a new one) and select the content type from the list. 
  5. Choose Edit task form and make the necessary modifications to it. In this case my data actually gets stored