Solved

Nintex Date Time Error - Supplied DateTime did not have Kind property

  • 18 December 2017
  • 2 replies
  • 13 views

Hi,

I have a site workflow running to capture all 'dates' from a column in a list. The dates are stored in a 'DateCollection' and the below output is what is stored inside.

Right after this (storing) I am getting the error (see bottom) The error appears to be happening when I try to loop through this 'DateCollection' - is the time attached is the problem? How can save some dates and loop through them without involving time?

RequestorId: f6ab5ed2-59f5-24fb-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ArgumentException: The conversion could not be completed because the supplied DateTime did not have the Kind property set correctly. For example, when the Kind property is DateTimeKind.Local, the source time zone must be TimeZoneInfo.Local. Parameter name: sourceTimeZone at System.TimeZoneInfo.ConvertTime(DateTime dateTime, TimeZoneInfo sourceTimeZone, TimeZoneInfo destinationTimeZone, TimeZoneInfoOptions flags, CachedData cachedData) at System.TimeZoneInfo.ConvertTimeFromUtc(DateTime dateTime, TimeZoneInfo destinationTimeZone) at System.Activities.CodeActivity`1.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation) Exception from activity ConvertTimeZone If Sequence DynamicActivity<DateTime> ToString FormatString DynamicActivity<String> Log to History List ChildActivityStep Sequence ForEachKeyValuePairStep ForEachSequence If DynamicValue Is Not Empty And Number of Items Greater Than 0 For Each Branch Parallel Block Sequence Flowchart File Availability Verification

Thanks for your time!

icon

Best answer by fhunth 18 December 2017, 17:43

View original

2 replies

Badge +13

Take a look at this answer on this post >>>  

I'm having the exact same issue, but I can't see where this solution is linking to, it's just ">>>"

 

Can anyone help?

Reply