Integrate K2 and UiPath - Error: (405) method not allowed

  • 28 September 2023
  • 2 replies

Badge +1

Hello everyone,


I’m following this guide How To: Integrate K2 and UiPath | Community ( but i’m not getting it to work when i create a service instance using the oauth i created. I have tried with the swagger file that is provided in the guide and also getting the swagger file from my uipath on prem by going to baseurl/swagger/index and that didn’t work aswell.



Nothing seems to work for me and i’m stuck.


Is there any other way to integrate the two? I’m trying to send a request to our orchestrator but i can’t even get the api to work


Best answer by RawanAyoubSogeti 6 October 2023, 14:51

View original

2 replies

Userlevel 1
Badge +5

Hello @RawanAyoubSogeti ,

I have recently helped a customer with this setup.

Can I ask if you are using UIPATH cloud?

If so, you may need to follow the documentation here:


Once you setup all the resource types, parameters and then adjust the resources. You can then go and create your service instance using the ‘Client Credentials OAuth resource’ credientials.


Interestingly also, the client I had an error return ‘invalid_client’ with using the enterprise account they had. When configuring against a demo evaluation account, it worked. So just watch out for this just in case.




Badge +1

Hej Anthony,

As the customer had an on-prem solution, i thought the Automation Cloud would not work so i did not even try it to begin with. But i realized that the two applications are exactly the same so when i followed that guide and used the client_credentials grant type it worked :D 

So to anyone out there that is struggeling with connecting using external applications, cloud is the same as on prem and use the client credentials part to connect using external applications