K2 Package & Deployment - NEXT button disabled

  • 26 March 2019
  • 5 replies

Badge +7

I have a K2 package that I'm ready to deploy


I have opened the package using the P&D app, on the destination server, logged in using the K2 Service Account, which also has local admin rights.


The package analysis completed successfully.


I have been through each item to select the appropriate actions and ensured that every single item has a green check mark


The P&D app has the NEXT button disabled, and no matter what I do, it will not enable.


I have tried setting the action for every item to "Create a new version ..." and re-analysing, but this does not resolve the issue.

5 replies

Hi Bushanborole,

I assume you have just upgraded to another K2 environment? If that is the case, your package contains some legacy workflows which could be the reason for this issue. However, you would need to apply a FP to your environment to resolve the issue and get the Next button enabled.

Having said the above, did you perhaps upgrade your environment? If yes, from what version to which version of K2? With this information, I will be able to suggest a specific fix pack that can resolve your issue.


Hello bhushanborole 


My suggestion would be selecting partial radio button on the select package screen.


If the above answered your question, kindly mark as "Kudo and/or Accepted Solution".


K2 will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member



Badge +9



Changing to “Partial Analysis” allowed the deployment to continue. Partial analysis does not enforce dependency check
This could be caused by some SMOs that were not able to deploy successfully prior to reaching the form




Hi  @BB33


This issue was solved here and the solution worked for the majority k2 Developers, I kindly encourage you to follow through the spot prompts to resolve your issue https://community.k2.com/t5/K2-Blackpearl-Forum-Posts/K2-Package-amp-Deployment-NEXT-button-disabled/m-p/67506#M19244


Should you find content from the above links useful and/or answered your question, Kindly Mark such as "Accepted Solution and/or Kudo", remember we're updating and putting content avalilable for other community members to use.


Kind regards;


Badge +9

Hi bhushanborole


See attached kb article in order to resolve you issue http://help.k2.com/kb002400


Should you find the information from the article useful or leading you to the answer please mark as "Solution and/or Kudo", as it will assist other k2 developers with relevant information in the near future.


Best Regards



[K2 will not accept any liability for any issues arising from actions taken in respect of the information provided by any forum member]