Identity Table is not refreshed

  • 7 March 2017
  • 1 reply



I have experiened that Propertes column (XML) is not refreshed in Identity.Identity table. Even I tried to run the SQL script to refresh User Role Manager. that column is not refreshed. Therefore updated email and other updated information (such as display name) are outdated. How could i refresh Properties column (XML) of identity.identity table. I used first option script ( but Properties column (xml) is not refreshed. K2 service account has permission on the AD. If it is new user, K2 get all information from AD and add it into Identity.Identity table. After that, whichever update to email or display name. K2 didn't refresh. I ran script to refresh the user role manager cache. restart the K2 host. still no luck.


K2 is 4.7 and it is Development enviornment. I have to run K2HostServer.exe manually. Is it because of development environment? Note that the environment is upgraded from 4.6.9 to 4.7. 


Any suggestion will be appreciated.

1 reply



Try going to the tester tool and refresh the service instance of URM service, its the user role manager service.

Also about the development environment, yes it is true you need to k2hostserver manually because in development environment you will not have the k2 service running by itself.