Base64string Will Not save to Database From K2

  • 14 January 2019
  • 3 replies
  • 0 views

I have this problem, I have been able to integrate Topaz Signature Pad to K2 , now  I am trying to save the Base64string i got from a digital signature pad to the database , I have been able to get the string to the Textbox but for a week now , i have been trying to save the string to a database and it still returns null value in the Database column.

Looks like this

 


3 replies

Hi,



Are you trying to just save the base64 string as it is, into your database? What data type did you specify for the column that will be saving this string? And what data type did you specify in your SmartObject?


 

i used a Webservice , converted and registered to a create a SmartObject.

I set the Base64 column as Varchar(max)

Hmm...Try changing your column to nvarchar(max).


 


If that does not work, try enabling SmartObject logging, test your form again, and check your SmartObject logs. With SmartObject logging enabled, you should see a log called brokerpackagein.log. It should show you the SmartObject you are executing, and what input and parameter is being passed into it. This allows you to debug your SmartObject and determine if your SmartObject is properly handling the correct data.


 


If the log is showing the correct base64 string being used in your SmartObject, then the problem is most probably coming from your database.

Reply