cancel
Showing results for 
Search instead for 
Did you mean: 

Error When Activating Site Collection Feature: "The field with Id {} defined in feature {} was found in the current site collection or in a sub site."

ISSUE
When activating the Nintex Workflow Site Collection Feature within SharePoint, the activation fails with the error: 

The field with Id {} defined in feature {} was found in the current site collection or in a sub site.
ERROR CODE
The field with Id {} defined in feature {} was found in the current site collection or in a sub site.
RESOLUTION

Option 1

Retract all of the Nintex Workflow solutions in the following order:
  • nintexworkflow2013enterprisefeaturesbackwardscompat.wsp (If applicable) 
  • nintexworkflow2013enterprisefeatures.wsp (If applicable) 
  • nintexworkflow2013backwardscompatibilityui.wsp (If applicable) 
  • nintexworkflow2013.wsp 
  • nintexworkflow2013core.wsp 
Re-deploy them in the following order: 
  • nintexworkflow2013core.wsp 
  • nintexworkflow2013.wsp (both to content web apps, and Central Administration) 
  • nintexworkflow2013backwardscompatibilityui.wsp (If applicable) 
  • nintexworkflow2013enterprisefeatures.wsp (If applicable) 
  • nintexworkflow2013enterprisefeaturesbackwardscompat.wsp (If applicable) 

Option 2

  1. Export a copy all of the Site Collections' sub sites using the Export-SPWeb command
  2. Delete the sub sites, and remove them from the Recycling Bin and Second Stage Recycling Bin
  3. Activate the Nintex Workflow Site Collection features (these will now activate without error)
  4. Import the sub sites back under the Site Collection using the Import-SPWeb command
ADDITIONAL INFORMATION
RELATED LINKS
Version history
Revision #:
1 of 1
Last update:
‎11-29-2018 12:12 PM
Updated by: