cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

"Custom" Site Template does not work with "Create Site Collection" action

Hello,

I was just trying to make a workflow action that creates a new Site Collection using a template, stored in the actual site collection where the workflow is running.

I have it in the dropdown for selection and everything, but by running the workflow, I get an error, that something is wrong with the template.

I just saved a plain "Teamsite", nothing special in there, just the OOB template, saved under a custom name.

The Error message is "Error creating site collection. Invalid File or Arguments for web template (then some name and ID stuff) Parametername: WebTemplate"

The Action is working correctly, if I pick a OOB template like "Teamsite" as template, only not working with the "custom" template.

Server is a SharePoint 2013 Standard with Nintex Enterprise Current version.

Thanks in advance!

0 Kudos
Reply
2 Replies
Not applicable

Re: "Custom" Site Template does not work with "Create Site Collection" action

More Information from the logs:

Nintex.Workflow.NWActionExecutionException: Error creating site collection. ---> System.ArgumentException: Invalid file or arguments for webtemplate '{5BEAFCCE-C7C8-44CC-B074-F1928526485E}#Template1'.  Parametername: WebTemplate     at Microsoft.SharePoint.SPWebTemplateCollection.get_Item(String strKey)     at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate, Page page, SPFeatureDependencyErrorBehavior featureDependencyErrorBehavior, ICollection`1& featureDependencyErrors)     at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate)     at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32 nLCID, Int32 compatibilityLevel, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName, Boolean overrideCompatibilityRestriction)     at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPSiteSubscription siteSubscription, String siteUrl, String title, String description, UInt32 nLCID, Int32 compatibilityLevel, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, Boolean useHostHeaderAsSiteName)     at Microsoft.SharePoint.Administration.SPSiteCollection.Add(String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail)     at Nintex.Workflow.Activities.CreateSiteCollectionActivity.Execute(ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)     at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)     at System.Workflow.Runtime.Scheduler.Run() 

Like I said, its a completely OOB Teamsite which I saved as template, no further custom things done on it.

Any Ideas?

0 Kudos
Reply
Automation Master
Automation Master

Re: "Custom" Site Template does not work with "Create Site Collection" action

I had this issue in the past, not related to workflows, but trying to create site collections based off of templates I created. My resolution was doing an IISRESET then trying again. There are some powershell scripts you can run to make sure your template is available for use too.

0 Kudos
Reply