cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
efarley
Nintex Newbie

User profile lookup doesn't work will all users

Attempting to use user profile lookup inline function in Nintex forms, to lookup a user's email, from their user account, so that I can use it to lookup a value in another list, where the only common field is the user's email.  This works fine for some user accounts, but fails to resolve other user accounts.  We have compared accounts that resolve, to accounts that don't resolve, and can't find any difference in their setup.  Any ideas what could be the issue?

Labels: (2)
0 Kudos
Reply
4 Replies
Automation Master
Automation Master

Re: User profile lookup doesn't work will all users

Hi Ellen,

did you check user profiles in sharepoints user profile service and made sure everyone has a work email? Do you receive any kind of error message when querying the profile unsuccessfully?

Regards

Philipp

0 Kudos
Reply
efarley
Nintex Newbie

Re: User profile lookup doesn't work will all users

Yes, all of the users, for which it is not resolving the user account, have email addresses. And there is no error message…in fact, it almost looks as if it doesn’t even perform the query, as there is no change to the calculated value fields when one of these user accounts is selected.

Ellen Farley

PH 973-254-4425 Cell 302-312-1901

0 Kudos
Reply
rangelin
Nintex Newbie

Re: User profile lookup doesn't work will all users

This issue is because the user probably has never accessed SharePoint...

I know it has been over a year and a half but this is a real issue for me and I am wondering if someone has found a way to get the Display Name without the userProfileLookup function. While this is a great function it does not work for a user who has never accessed SharePoint. At our business we have people in a production environment who never use computers and therefore never use SharePoint. But there supervisor needs to fill out a form requesting pay changes for the employee and the userProfileLookup will not find any information for that user because of them never having used SharePoint. However the People Control will find the user in Active Directory and have their login ID and Display name. But all I can seem to get back from the People Control is the login ID in the form of "i:0#.w|domain\userid". If I ask how to get the users Display Name the answer is always to use the userProfileLookup, but it does not work because of the above issues. So how can I get the Display Name form the People control?...because I know that it has the Display Name because it displays it when I lookup the name.   Thanks!

Reply
rangelin
Nintex Newbie

Re: User profile lookup doesn't work will all users

I would like to post a reply to my own post to tell my experience in hopes that it will help someone else. I hope this is not plainly obvious to SharePoint experts out there . While doing another task namely setting up Audiences, I discovered that my User Profile Synchronization was not working because I only had 300 profiles that had been synchronized. When comparing with our SharePoint 2010 server there were many 1000s of profile objects. Looking into it further, the User Profile Service Application was set to run daily at 1 AM BUT also set to run no later than 1 AM. Therefore it never actually was running!  I manually kicked off a Profile Synchronization and after awhile I have many 1000s of profile objects synchronized as well on this server. I set the User Profile Service Application to run from 1 AM to 6 AM daily. Now the issue with the userProfileLookup function is no longer an issue. I am able to query every user whether they have used SharePoint or not.

To configure the User Profile Service Application:

  • Open SharePoint Central Administration | Application Management | Service Applications | Manage service applications
  • Find User Profile Service Application in the list and click on it (if you named it something different you can find it by the type).
  • The Profile statistics are listed to the right side of this page.
  • Under Synchronization I clicked on Configure Synchronization Timer Job to configure it.
  • To manually start a synchronization I clicked on Start Profile Synchronization.

This seems rather simple now but I hope that this will help someone else out there.

Thank you.

Reply