cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
barryc
Nintex Newbie

Nintex Mobile iOS Form Can't Add Up!

Jump to solution

I have a problem with a Nintex Mobile form I am creating which manifests itself in the iOS app (latest version) but not in the Windows version.

In my form I have a repeating section where each row contains several integer fields - they have a default value of zero. I want to include a total of these fields.

In testing I considered the scenario where a user might leave the zero in the field and then add the real number.

So for example, they might type:

09 or 011 or 0500

What I have observed is that whenever the number has leading zeroes, is 010 or greater and doesn't contain an 8 or a 9 any calculation based on it is incorrect!

In the examples above, if I simply create a calculated field = to the data field I see the following:

09 = 9

011 = 9

0500 = 320

As mentioned, any number that contains an 8 or a 9 is correctly calculated.

This does not happen if I open the form in the Windows app, only the iOS app (I haven't tested Android).

I have tried replacing the leading zeros using regex and the result is exactly the same. It does not matter whether the data field or the calculated field have a datatype of string or integer, I get the same result. 0500 = 320!

Any suggestions on how I can convince the iOS form that 0500 = 500!?

The form is built using Nintex Forms on Office 365.

Labels: (3)
0 Kudos
Reply
1 Reply
barryc
Nintex Newbie

Re: Nintex Mobile iOS Form Can't Add Up!

Jump to solution

Closing the loop on this.

I raised this with Nintex Support and it was accepted as a bug. The numbers were, for whatever reason, being treated as octal and not decimal. This explains why numbers containing 8 & 9 seemed to work fine, because Octal numbers contain only the numbers 0 - 7.

I have just installed the latest Android build (4.1) and the issue seems to be resolved.

0 Kudos
Reply