cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
jeremy_bennett
Nintex Newbie

Nintex Form Not Running Validation Rules & Closing Form Prematurely

I have a Nintex Form with a few validation rules associated to controls (i.e., if this field is not blank then that field is required, etc.) When I publish it one of two things happens - either the rules will run as expected and the fields will highlight in a red box but then suddenly the form will close or the rules don't run at all and the form closes. I have searched the Nintex site for clues but have come up empty.

Any ideas or help is much appreciated.

Labels: (2)
Reply
9 Replies
courtney_shelto
Nintex Newbie

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

Hmm, how many rules do you have on the form? Sometimes a large number of rules can make things be a little screwy.

0 Kudos
Reply
Automation Master
Automation Master

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

open developer console and then run your form.

check for any error reported on the console.

0 Kudos
Reply
Automation Master
Automation Master

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

duplicate question to this -  

0 Kudos
Reply
merru
Nintex Newbie

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

I am having this exact issue. I tested with just a simple validation rule isNullorEmpty(self) and it is either not running or it shows a red frame around for few seconds and then closes the form.

0 Kudos
Reply
loi0404
Nintex Newbie

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

I'm having an identical issue - I'm using a default content type, so that doesn't appear to be the source.

I've also stripped out custom scripting/css. Test lists on the same environment & site seem to work.

0 Kudos
Reply
loi0404
Nintex Newbie

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

I've resolved this.

The problem was a validation rule embedded in a control setting that fail.

Nintex processes validations as a sequence, so when one logic errors out, all subsequent rules are ignored.

Reply
Mukesh_Shewale
Nintex Newbie

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

i have more than 30 fields which assigen required field validation ... but not working
0 Kudos
Reply
Automation Master
Automation Master

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

@Mukesh_Shewale: Please start a NEW forum thread that gives us more information about your problem and it is likely that somebody will be able to help you! 

Please provide screen shots and an example of exactly what is happening. 

Thank you. 

0 Kudos
Reply
Mukesh_Shewale
Nintex Newbie

Re: Nintex Form Not Running Validation Rules & Closing Form Prematurely

Please find below screen shot.The same validation working fine on other form only this form validation are not working.

Thank you in advanced

0 Kudos
Reply